Store presets for different arguments for the custom processor, invoke arguments on a per-document basis

Ood's Avatar


17 Feb, 2014 03:20 AM

Love using Marked2 with pandoc as my custom processor for scholarly citations.

One feature request, if I may: would it be possible to save presets of arguments used in the custom processor? Even just a drop down arrow in the arguments field showing previous arguments that you'd entered would be really handy. With pandoc, I sometimes switch back and forth between different CSL style sheets, and it would save me some typing if it could remember or store previous arg somehow.

What would also be really excellent, is if we could have a per-document settings for custom processor arguments. At the moment there one for turning the processor on and off:

Custom Processor: true

It would be fantastic to also have something like:

Custom Processor Args: --bibliography /Users/ood/Dropbox/Notes/mylibrary.bib --csl /Users/ood/Dropbox/Notes/modern-humanities-research-association.csl

Thanks for a fantastic app!

  1. Support Staff 1 Posted by Brett on 17 Feb, 2014 02:51 PM

    Brett's Avatar

    That's a good idea. Eventually Marked will be able to handle multiple custom processors and arguments and you'll be able to call them by name in metadata, but this would be a good stopgap. I'll add it to the todo list.


  2. 2 Posted by Ood on 06 Mar, 2014 05:45 AM

    Ood's Avatar

    Hi Brett

    I'm having problems using a file path with a space in it in the args for the custom processor (pandoc)

    If the bib file is here, it works fine:


    But if it's here:

    /Users/ood/Box\ Documents/mylibrary.bib

    The pandoc doesn't work, and I just see the output without the custom processor (it's the exact same bib file, I copied it across the two locations)

    This happens whether or not I "escape" the space with the backslash . Am I escaping the space wrong? Is there a different way of doing this?

    Having the library in the Box\ Documents path works fine using Pandoc from the command line, I just have this issue using pandoc as the custom processor in Marked 2

  3. Support Staff 3 Posted by Brett on 06 Mar, 2014 03:02 PM

    Brett's Avatar

    I'm going to have to do some testing on this. I've added it to my todo
    list and will try to get back to you early next week.


  4. Support Staff 4 Posted by Brett on 14 Mar, 2014 05:43 AM

    Brett's Avatar

    @Ood: Have you tried quoting the filepath instead of escaping it?

  5. 5 Posted by Ood on 14 Mar, 2014 05:48 AM

    Ood's Avatar

    Yes, it doesn't work either way

  6. Support Staff 6 Posted by Brett on 14 Mar, 2014 06:17 AM

    Brett's Avatar

    Ok, I still need to get a setup going that I can properly test with.
    I'll keep you posted.


  7. 7 Posted by Ood on 29 Aug, 2014 02:15 PM

    Ood's Avatar

    Hi Brett

    Have there been any developments on the problem with spaces in file path names? (I noticed that someone else seemed to be having a similar problem with "Google Drive" in the file path)

  8. Support Staff 8 Posted by Brett on 29 Aug, 2014 02:17 PM

    Brett's Avatar

    Yes, I have spaces in arguments fixed for the next update.

  9. 9 Posted by Ood on 29 Aug, 2014 02:22 PM

    Ood's Avatar

    Fabulous, looking forward to it.

    I also had that pandoc permission issue that is described in the long pandoc thread. I'm pleased to say that the fix suggested there, of dragging the folder containing the bib and the csl onto Marked, worked for me.

  10. 10 Posted by Ood on 07 Oct, 2014 09:54 AM

    Ood's Avatar

    Hi, I'm now on the latest version, Version 2.4.6 (859)

    Experimenting with the "spaces breaking file paths in the arguments of the custom processor" issue, what I've found is that it only works if I put quotation marks around the path AND I escape the spaces with backslashes, like this:

    --bibliography "/Users/Ood/Box\ Sync/Papers2/mylibrary.bib"

  11. Support Staff 11 Posted by Brett on 07 Oct, 2014 02:11 PM

    Brett's Avatar

    Really? I'll have to do some more testing, my apologies.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac