Custom processor (pandoc with bibliography):: how to set-up the args?

andrzej.wodecki's Avatar


03 Dec, 2019 08:00 PM


inspired by: <<< see point 4.0 at the bottom
I would like to set-up a custom processor using pandoc with citations.

The command that works for me in a terminal looks like that:
pandoc -s --bibliography my_library.bib --filter pandoc-citeproc -o file.pdf

my_library: is a file with bibliographical entries a file I would like to preview
file.pdf: a file with converted pdf

I've tried different options of args in Preferences > Advanced > Enable Custom Processor > Args
but none of them worked.

I would appreciate any help,

Many thanks in advance :)


  1. Support Staff 1 Posted by Brett on 03 Dec, 2019 08:43 PM

    Brett's Avatar

    Your working terminal command outputs a PDF, you need to ensure that
    you're outputting HTML. Then you should be able to set the processor to
    /usr/local/bin/pandoc and the rest of the arguments in the arguments


  2. 2 Posted by andrzej.wodecki on 04 Dec, 2019 12:04 PM

    andrzej.wodecki's Avatar

    Thnks, Brett,

    I've changed:

    path: /usr/local/bin/pandoc
    args: --bibliography biblio.bib --filter pandoc-citeproc -t html5
    with "biblio.bib" beeing a full path to my biblio.bib file

    and still get the error:

    *Error running custom processor*

    [WARNING] Could not deduce format from file extension or . or . or or or
    or or or or . or .bib" or

      Defaulting to markdown

    pandoc: : openBinaryFile: does not exist (No such file or directory)

    I've also tried args as

    --bibliography biblio.bib --filter pandoc-citeproc -t html5

    -s -f markdown --bibliography biblio.bib --filter pandoc-citeproc -t html5

    but no success.

    Any idea?

    Many thanks,


    wt., 3 gru 2019 o 21:43 Brett <[email blocked]> napisał(a):

  3. Support Staff 3 Posted by Brett on 04 Dec, 2019 01:43 PM

    Brett's Avatar

    See if this helps at all:

    There have been a lot of discussions like this on the forums, some of
    which may be helpful. Personally, I'm not well versed in Pandoc options
    and can't offer a lot of support for 3rd party processors. But the
    answers are here with a little searching.


  4. 4 Posted by andrzej.wodecki on 04 Dec, 2019 02:10 PM

    andrzej.wodecki's Avatar

    OK, thanks :)


    śr., 4 gru 2019 o 14:43 Brett <[email blocked]> napisał(a):

  5. 5 Posted by Jo on 04 Dec, 2019 06:04 PM

    Jo's Avatar

    I'm not sure to understand.

    If you only want to use Pandoc-citeproc to generate bibliography in Marked 2 previewer, you don't have to write all the command line.

    For example, in my case :

    Path : /usr/local/bin/pandoc
    Arg : -s --filter pandoc-citeproc --bibliography /Users/mynane/Pandoc/Library.bib --csl /Users/myname/Pandoc/apa.csl

  6. Support Staff 6 Posted by Brett on 04 Dec, 2019 07:29 PM

    Brett's Avatar

    Is this a question? I don't understand.

  7. 7 Posted by andrzej.wodecki on 04 Dec, 2019 07:29 PM

    andrzej.wodecki's Avatar

    Many thanks, Jo,

    that works :)

    But... My "error" was completely different: a path to my .bib file
    contained whitespaces.
    In terminal you escape them either with " ", ' ' or \.
    Arg field in Mark 2 doesn't allow such escapes, and, at the end of the day,
    whitespaces in paths at all...

    When I put my csl and lib file in /Users/mynane/Pandoc/ (no whitespaces in
    a path) - that works :)

    Many thanks once again,


    śr., 4 gru 2019 o 19:04 Jo <[email blocked]> napisał(a):

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac