Disable auto refresh?

Brandon's Avatar


08 Dec, 2015 03:18 PM

I'm using Markdown with nvALT. I'm wondering if it's possible to disable auto-refreshing in Marked for two reasons:

  • It looks like nvALT autosaves a few seconds after I make some change in the text. This causes Marked to refresh and scroll back down to where I was editing. It appears that it sometimes saves twice, however, causing the Marked window to repeat the "scroll to top, then scroll to last edit" again. If every edit I'm making causes Marked to scroll to the top and back to the last edited position, it can be pretty jarring.

  • Sometimes I'm viewing Marked in one spot and making changes to the file in another spot. It would be good if I could disable refreshing in Marked, otherwise I have to keep scrolling up/down after every change.

A workaround for both of these is to use a third party editor that doesn't autosave. Of course, if there's a way within Marked to tell it to stop refreshing, that would be ideal.

  1. Support Staff 1 Posted by Brett on 08 Dec, 2015 04:11 PM

    Brett's Avatar

    Just disable "scroll to first edit" in Preferences->Preview.


  2. 2 Posted by Brandon on 08 Dec, 2015 04:19 PM

    Brandon's Avatar

    Unfortunately that causes Marked to scroll to the top of the document any time an edit is made in nvALT, so I'd need to keep scrolling to the spot I was looking at each time.

  3. Support Staff 3 Posted by Brett on 08 Dec, 2015 04:30 PM

    Brett's Avatar

    Odd, that scroll to top shouldn't be happening, I'll need to look into

    There's currently no way to disable the auto refresh, as that would
    defeat the purpose of Marked for the most part. In the case of nvALT,
    the preview window might be sufficient without the same issues, and it
    can be "pinned" to prevent any changes until you unpin it.


  4. 4 Posted by Brandon on 08 Dec, 2015 04:34 PM

    Brandon's Avatar

    Hehe, I actually bought Marked to gain some of the benefits over the nvALT Preview window. It at least makes me feel a little saner that it shouldn't be always jumping to the top.

    In the meantime I'll stick with the workaround of using another editor. If you need help reproducing it, logs, etc. let me know.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac