Marked doesn't notice changes

iay's Avatar


13 Sep, 2011 03:50 PM

I have two machines on which I've just installed Marked from the app store. Both are running Lion upgraded a few weeks ago from Snow Leopard.

On one of these, everything works perfectly: when I save the file in the editor (Byword, TextMate, TextEdit, whatever) Marked immediately updates the preview.

On the other machines, Marked doesn't notice the change. I can force it to refresh with Cmd+R, but that's obviously suboptimal. This seems to be the case with various editors, and with the file in various directories.

Spotlight on this second machine is running, with no exclusions. If I put a word that appears nowhere else into the file, Cmd+S and look for that word in spotlight, the file shows up which kind of indicates to me that Spotlight is working, but there is obviously something wrong.

Any ideas, suggestions?

  1. Support Staff 1 Posted by Brett on 13 Sep, 2011 04:01 PM

    Brett's Avatar

    Could you take a look at Console (/Applications/Utilities/ at the time you save and see if Marked is giving you any messages?

  2. 2 Posted by iay on 13 Sep, 2011 04:19 PM

    iay's Avatar

    I don't see anything in system.log from Marked (is that the right log file to be looking in?).

    I do see these from time to time in system.log:

    fseventsd[16]: SLOWDOWN: client 0x7fde9100a000 (pid 92) sleeping due to too many errors (num usleeps 502)

    I know that fseventsd underlies spotlight at some level, but in this case I think it's whining about MozyHomeBackup being asleep; as I say, spotlight itself seems to be working.

  3. Support Staff 3 Posted by Brett on 13 Sep, 2011 04:30 PM

    Brett's Avatar

    Hmmm, ok. At your command line, type `defaults write com.brettterpstra.marky debugMode 1` and check system.log again. If it's getting any notifications from the Spotlight query system, you'll see something. If it's quiet, then Spotlight is not sending the necessary change notifications.

    If that's the case, I'd suggest rebuilding your Spotlight index (`mdutil -E /` for the main hard drive). That takes a while but tends to fix a lot of issues. The other step you might try is doing a disk repair (Disk Utility->Repair Disk), but that's kind of voodoo that only helps once in a while. Please let me know if that helps!

  4. 4 Posted by iay on 13 Sep, 2011 06:16 PM

    iay's Avatar

    I can see messages on file load after setting debugMode to 1. However, I'm still not seeing anything when the file is saved.

    I had already tried a permissions repair and have just tried a disk repair (there was one hard link count problem) with no change.

    I will try the spotlight rebuild next.

  5. 5 Posted by iay on 14 Sep, 2011 07:41 AM

    iay's Avatar

    Rebuilding the Spotlight index fixes my problem.

    Many thanks!

  6. Support Staff 6 Posted by Brett on 14 Sep, 2011 01:19 PM

    Brett's Avatar

    Awesome, glad to hear it!

  7. 7 Posted by OmarKN on 09 Aug, 2012 10:22 PM

    OmarKN's Avatar

    With the same issue, I'm trying to index the Spotlight db, but get this error mess:

    i3:~ okn$ sudo mdutil -E /

    Indexing and searching disabled.

    i3:~ okn$

    ANy idea what to do now?
    bw, Omar KN

  8. Support Staff 8 Posted by Brett on 09 Aug, 2012 10:29 PM

    Brett's Avatar

    sudo mdutil -i on /

    Turns on indexing. Let me know if that helps.

  9. 9 Posted by OmarKN on 09 Aug, 2012 10:36 PM

    OmarKN's Avatar

    Nope, I get:

    Indexing and searching disabled.

    /bye okn

  10. Support Staff 10 Posted by Brett on 09 Aug, 2012 10:43 PM

    Brett's Avatar

    What OS version are you on, and are you booting from a network drive?

    You can try:

    sudo launchctl load -w /System/Library/LaunchDaemons/

  11. 11 Posted by Omar KN on 09 Aug, 2012 10:49 PM

    Omar KN's Avatar

    Hi & good day,

    This is OS 10.7.4, local drive,

    and I got: Already loaded

    Omar KN

  12. Support Staff 12 Posted by Brett on 09 Aug, 2012 10:52 PM

    Brett's Avatar

    Have you opened Spotlight preferences, made sure it's turned on and that your drive isn't listed under Privacy preferences?

    I'm afraid I can't help you much further than that. You're may need to find a utility like Cocktail that can handle enabling, disabling and re-indexing.

  13. 13 Posted by OmarKN on 09 Aug, 2012 11:05 PM

    OmarKN's Avatar

    Well, I had the drive with my Applications excluded, sorry for that.

    Also now for Spotlight, I get: Indexing enabled, and now it rebuilds the db, let's see what happens next :-)

    / bw, OmarKN

  14. 14 Posted by OmarKN on 10 Aug, 2012 01:49 AM

    OmarKN's Avatar

    Hi, ok after the Spotlight-Indexing,
    I did a logg-out--logg-into the OS and sweesh,
    everything is working nicely, thank you!

    bw, Omar KN

  15. Brett closed this discussion on 26 Aug, 2012 08:07 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac