Scrivener document titles don't appear as headers unless the document has content

Fred's Avatar


09 Apr, 2012 08:30 AM

When using Marked with the option to use document titles from Scrivener as Markdown headers, the document titles don't appear in Marked as headers unless the documents have content. Nested documents under the empty document aren't enough to make it show, but the nested document titles themselves show up if they have content. A single space in the document is sufficient to make the title appear, and obviously the space has no other influence on the output.

I was wondering if this was a bug, a conscious decision or a limitation due to the way Scrivener treats empty documents.

Thanks for the great update!

  1. Support Staff 1 Posted by Brett on 09 Apr, 2012 11:10 AM

    Brett's Avatar

    I'll have to look into it again. The titles should be there, but the cache files Marked uses may not be. I'll see if I can find a fix.


  2. 2 Posted by jose on 30 Jun, 2012 11:09 PM

    jose's Avatar

    Hi Brett, related with this issue, I neither see in Marked the footnotes I add in Scrivener being "converted to a MultiMarkdown footnote in the preview" as described in Marked Help page.

  3. Support Staff 3 Posted by Brett on 30 Jun, 2012 11:11 PM

    Brett's Avatar

    Can you post a sample document so I can see how you're structuring the document and footnotes?

  4. 4 Posted by locative on 30 Jun, 2012 11:43 PM

    locative's Avatar

    Thanks for replying so quick. To test it again I created a blank document
    and added a footnote, I found the same problem. I'm using Scrivener 2.3 and
    Marked 1.4.

    The "include document titles and Markdown headers" is a great feature,
    combined with CSS counters I can add auto-numbering to titles in the
    previews. Unfortunately this numbers don't appear in the Table of Contents
    that shows after clicking the list button in the toolbar. Any plans to
    incorporate an option for this?

    2012/6/30 Brett <
    [email blocked]>

  5. Support Staff 5 Posted by Brett on 06 Jul, 2012 01:29 PM

    Brett's Avatar

    Are you asking for a numbered table of contents within the preview? That would be possible using the same CSS method. Would you care to save me time and show me the CSS you're currently using to add the counters in your doc?

  6. 6 Posted by locative on 06 Jul, 2012 09:22 PM

    locative's Avatar

    I attach the CSS (is the provided Custom CSS Example with some counters),
    although I'm not talking about getting a numbered table of contents within
    the preview itself (I neither know how), but about the table of contents
    that Marked offers when pressing ⌘. To see in this menu the titles numbered
    as in the preview will help navigation and citation while writing in

    2012/7/6 Brett <
    [email blocked]>

  7. Support Staff 7 Posted by Brett on 06 Jul, 2012 09:29 PM

    Brett's Avatar

    Great, yes, that's what I understood you to mean. I'll play with it and see if it's an option I want to include in the next release.


  8. 8 Posted by locative on 06 Jul, 2012 09:54 PM

    locative's Avatar

    Thanks a lot Brett. Also any guidance about getting a Table of Contents in
    the preview itself as you suggest will be very helpful.

    2012/7/6 Brett <
    [email blocked]>

  9. Support Staff 9 Posted by Brett on 07 Jul, 2012 06:42 PM

    Brett's Avatar

    You can't see it in the preview at this time. Because it's dynamically generated it would cause havoc with the scroll-to-edit feature. If I rewrite it in Objective-C, it may be possible, but given the custom processor ability I can't predict what the markup will look like during the initial processing. I'm looking into a solution for that, though, as it would improve the performance in the preview.

  10. Brett closed this discussion on 07 Jul, 2012 06:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac