Problems exporting to PDF

spochtskamarad's Avatar


23 Jan, 2013 08:39 AM

Hi all !

Marked is a great app but has a major problem when exporting as PDF.

I am wondering if this topic didn't pop up yet – may be it is configuration of our infrastructure. System configuration here is MacOSX 10.7.5 using german locales.

There are 3 main problems when exporting a rendered markdown document as a PDF:
1. the PDF is rendered at wrong size (45 cm x 66 cm, see attached screenshot)
2. the output is in landscape format if I select "Save as PDF"
3. there is no way to change to layout from landscape to portrait; there is no selection widget for this action visible

Things I tried so far without success:
- changing the output css (tried with "swiss", "github" and our corporate css which didn't change a thing) - changing the system wide language to english as first language (because the application language and the printing dialog is english) - accessing different printers - export as PDF - saving to PDF via the print menu - exporting PDF into Preview and trying to export from there (leaving a lot of white space on the pages; no, this is not an option)

Any hints?

Thanks in advance,


  1. Support Staff 1 Posted by Brett on 06 Feb, 2013 03:43 AM

    Brett's Avatar

    I'm afraid PDF support for non-US layouts is missing in Marked 1.4. I've improved the print options for the next version, but for now the best solution is to export HTML and then save as PDF from Safari or other converter.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • readme-swiss-layout.png 50.8 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac