Running with custom processor produces a paragraph of metadata at the first line of the preview

tobeplugged's Avatar


03 Feb, 2012 08:16 PM

Hey everybody,

I hacked together a custom processor for Marked to generate previews for my pelican blog including code highlighting via pygments.

Everything works perfect, except one thing:
In the preview of Marked there is a

<p>Quotes Language: english 
Base Header Level: 1</p>

inserted, which is not produced by the processor.
Any Ideas?

  1. Support Staff 1 Posted by Brett on 03 Feb, 2012 08:36 PM

    Brett's Avatar

    Oh, my bad. That's inserted for the MultiMarkdown processor, but shouldn't be triggered if you enable a custom processor. I'll check that bit of the code and fix it for the next release.


  2. 2 Posted by bussard on 06 Mar, 2012 03:10 PM

    bussard's Avatar

    I'm not using a custom processor but I simply use TextEdit or MMD Composer to produce text, and I get the same bit of code at the top of each document. Will the next release of Marked also remove the code for regular use?


  3. Support Staff 3 Posted by Brett on 06 Mar, 2012 03:39 PM

    Brett's Avatar

    You see the code in the preview, or in output?

  4. 4 Posted by bussard on 06 Mar, 2012 09:34 PM

    bussard's Avatar

    In the Preview.
    And in the Saved output, if I select "include preview template in output" when selecting RTF as format to save in. If I uncheck the box in the Save dialog window, the code disappears, but instead the Metadata appear, wrapped in

    tags - which were suppressed in Preview.

  5. 5 Posted by Robert Esland on 07 Mar, 2012 09:05 AM

    Robert Esland's Avatar

    Hi Brett,

    The code appears both in Preview and in the Output (Save as RTF)

    There is Screenshot attached, showing the original text in TextEdit, saved as txt, the Preview window in Marked, and the rtf file which was obtained from Saving the Marked Preview output, with the checkbox re the template unchecked. I also tried with the template button checked: then the resulting RTF file resembles the Preview, i.e. code, but no Metadata wrapped inside <p> tags.

    MacMini Intel Core Two Duo, OS 10.6.8.


  6. Support Staff 6 Posted by Brett on 12 Mar, 2012 01:57 PM

    Brett's Avatar

    I believe I have this corrected for the next version. If it continues to be an issue after the release of 1.4, please let me know.

  7. 7 Posted by Robert Esland on 12 Mar, 2012 09:42 PM

    Robert Esland's Avatar

    Will do. Thanks!

  8. Brett closed this discussion on 26 Aug, 2012 08:53 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac