Problem while displaying a link with alternate text and # in the URL AND alternate text.

Alessandro Perucchi's Avatar

Alessandro Perucchi

02 May, 2021 08:55 AM

// Please enter a detailed description of the issue // Description of the issue:

If you put an # in an alternate text in a link, then the link is not displayed as a link, and the # is not displayed either.

Example that does not work:
[4] https://code.visualstudio.com/#alt-downloads

Example that does work:
[4] https://code.visualstudio.com/#alt-downloads

Another example that does work:
[4] https://code.visualstudio.com/alt-downloads

But with # on both the URL and alternate text, it does not work.

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. create an empty md file, with the line:

[4] https://code.visualstudio.com/#alt-downloads

And save it.

  1. Open the file in Marked.

  2. You will see the following text:

[4] [https://code.visualstudio.com/alt-downloads)

And as you can notice, this is not a link, and all the text between the 2 # included, were removed.

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit) Marked 2 1021 (Setapp)

macOS Version: 11.3

additionalMathJaxConfig:
allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: NO
convertGithubCheckboxes: YES
convertGithubEmoji: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 0
defaultProcessor: MultiMarkdown
enableMiniMap: YES
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: YES
hrIsPageBreak: NO
includeMathJax: YES
includeKatex: NO
limitTextWidth: NO
mathNumberEquations: NO
mathNumberEquationsSide: 0
mathNumberEquationsAMSOnly: NO
minimalJavaScript: NO
outlineModeExtensions:
permissionGranted: NO
printHeaderBottomLeft:
printHeaderBottomRight:
printHeaderFirstPage: NO
printFooterFirstPage: NO
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: YES
removeMetadataForPreview: NO
removeYAMLHeaders: NO
scrollToEdit: NO
shouldDetectCritic: YES
shouldHighlightMarkupErrors: NO
shouldLoadCritic: NO
syntaxHighlight: YES
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: NO
customMarkdownProcessor:
useCustomPreprocessor: NO
customPreprocessor:
useFirstH1AsPrintTitle: YES

  1. 1 Posted by Alessandro Peru... on 02 May, 2021 09:04 AM

    Alessandro Perucchi's Avatar

    Arglll... I have just notice that the forum has destroyed my examples... and my text....

    Ok, I will repeat it with the correct formatting output:


    // Please enter a detailed description of the issue // Description of the issue:

    If you put an # in an alternate text in a link, then the link is not displayed as a link, and the # is not displayed either.

    Example that does not work:

    \[4\] [https://code.visualstudio.com/#alt-downloads](https://code.visualstudio.com/#alt-downloads)

    Example that does work:

    \[4\] [https://code.visualstudio.com/alt-downloads](https://code.visualstudio.com/#alt-downloads)

    Another example that does work:
    \[4\] [https://code.visualstudio.com/#alt-downloads](https://code.visualstudio.com/alt-downloads)

    // Please enter a list of steps required to reproduce the issue // Steps to reproduce:

    1. create an empty md file, with the line:

    \[4\] [https://code.visualstudio.com/#alt-downloads](https://code.visualstudio.com/#alt-downloads)

    And save it.

    1. Open the file in Marked.

    2. You will see the following text:

    [4] [https://code.visualstudio.com/alt-downloads)

    And as you can notice, this is not a link, and all the text between the 2 # included, were removed.

  2. Support Staff 2 Posted by Brett on 02 May, 2021 11:41 AM

    Brett's Avatar

    This doesn’t seem to be happening for me. The only thing I can think
    of that would affect it is if you have “#text is tag” enabled in
    Processor preferences. Is that the case?

    Also, please confirm the preferences below: you’re using the
    MultiMarkdown processor and no custom processors?

    Thanks,
    Brett

  3. 3 Posted by Alessandro Peru... on 02 May, 2021 07:15 PM

    Alessandro Perucchi's Avatar

    You are right! I did not know about that option... Thank you!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac