Big Sur, Pandoc & Citeproc

simeonduckworth's Avatar


29 Nov, 2020 05:01 PM

Hi there

I am having problems with pandoc and with citeproc specifically. Not sure if it is to do with Big Sur or not, but the problems are 'recent'.

I get the error "pandoc: : openBinaryFile: does not exist (No such file or directory)" from the processor when I open Marked2 and when I run from the custom processor option

 "/Users/[name]/anaconda3/bin/pandoc --output file.html -f markdown  -t html5 --bibliography /Users/[name]/[file_path]/zotero_bib.json --citeproc"

But if i run the same command from the command line it works fine, rendering the document and adding the citations (both to HTML and to pdf), I've tried using "/usr/local/bin/pandoc". No joy in Marked, but works on the command line.

Not sure what to try next. Grateful for any help or pointers.

  1. Support Staff 1 Posted by Brett on 30 Nov, 2020 03:47 PM

    Brett's Avatar

    First impression without testing… you don't want the output to go to an HTML file, you want it to go to STDOUT, which I think is accomplished by just leaving the output flag out. However, that doesn't explain the missing file error.

    Usually that error also tells you what file is missing, specifically. Is there any more to the error message?

    This may also be a permissions issue. Are you on the Mac App Store or direct (Paddle) version?


  2. 2 Posted by Mark on 17 Dec, 2020 06:25 AM

    Mark 's Avatar

    % brew info pandoc-citeproc pandoc-citeproc: stable (bottled), HEAD
    Library and executable for using citeproc with pandoc
    Disabled because it is deprecated upstream!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac