Not more TOC available

Gilles Bisson's Avatar

Gilles Bisson

25 Oct, 2020 09:53 AM

Since sometime as soon as I import an image in a MD document :
1) <!--TOC--> directive doesnt work anymore, I get nothing
2) The interface is no more able to dispaly the header list of the document (first icon bottom right)
3) the word "processing" is always visible in the bottom of the rendering window (seems correlated with the two precedent issues)

Here is a very simple example of code that show the problem on my computer : the problem is the same if I use the tag to import a PNG file

# Any title nothing

I really don't know if :
- it is a bug - that I changed the "wrong" settings in Marked preferences (as far as I remember I changed nothing) - A consequence of the last macOs security update which caused some troubles a month ago

I tried to reboot my computer but the problem is still here

// Configuration (do not edit) Marked 2 1007 (Mac App Store)

macOS Version: 10.14.6

allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: YES
convertGithubCheckboxes: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 3
defaultProcessor: Discount (GFM)
enableMiniMap: NO
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: NO
includeKatex: YES
limitTextWidth: YES
minimalJavaScript: NO
permissionGranted: YES
printHeaderBottomRight: %page/%total
printHeaderFirstPage: NO
printFooterFirstPage: YES
processHTMLFiles: NO
removeMetadataForPreview: NO
removeYAMLHeaders: NO
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: YES
shouldLoadCritic: NO
syntaxHighlight: YES
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: NO
useCustomPreprocessor: NO
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 26 Oct, 2020 07:54 PM

    Brett's Avatar

    It's quite possible this has to do with sandboxing restrictions and a
    failure to load the image causing processing to hang. If you remove the
    "./" from the beginning of the image path, does that make a difference?

    If you want to test without sandboxing, download the free trial at and run that version to see if it has the same
    issue. If not, and that's the easiest solution, I'll provide a license
    key for the direct version free of charge.


  2. 2 Posted by Gilles Bisson on 26 Oct, 2020 08:29 PM

    Gilles Bisson's Avatar

    Hi Brett

    Thanks for your answer ...

    I tested the two solutions : removing the "./" in the path and using the free trial version however in both cases I have still the same problem : endless "processing" and no more acces to the TOC.
    I also tried with a very small JPG image and by moving the MD file in the same folder than the image, nothing works.

    Clearly the problem is relatively new : I worked on some (large) documents 6 months ago containing a TOC and at this moment all was right. Now no more TOC on the same files. A very puzzling behavior ...

  3. Support Staff 3 Posted by Brett on 26 Oct, 2020 08:38 PM

    Brett's Avatar

    Please attach a test document.


  4. 4 Posted by Gilles on 27 Oct, 2020 08:36 AM

    Gilles's Avatar


    Here is a small example and the screenshot of the rendering on my computer ...
    As you can see "processing" is displayed and I cannot open the TOC menu

    Hope this help ...

  5. Support Staff 5 Posted by Brett on 27 Oct, 2020 01:38 PM

    Brett's Avatar

    In my initial tests with your file and configuration I'm not able to
    replicate the issue. The fact that it only happens when you add the
    image is confusing (obviously it confuses you as much as it does me). If
    you remove the TOC marker but leave the image, does it complete
    processing fine? And in that case, does the popup TOC (⌘T) work fine?


  6. 6 Posted by Gilles on 27 Oct, 2020 02:33 PM

    Gilles's Avatar

    Hi Brett

    "If you remove the TOC marker but leave the image, does it complete processing fine?" NO And in that case, does the popup TOC (⌘T) work fine? NO

    But I think I solved the problem !

    Currently I am working on multi-users project using the official Github Desktop application to manage the accesses. Thus, all my data files are stored in a local copy of the github account (on my laptop disk), in several shared folders.
    Now, If I move the example dataset out of its shared folder, all becomes correct with Marked 2, even if I keep this dataset at the level of the github folder. So the problem seems to came from the fact that the data was inside a (github) SHARED folder.
    I suspect that this issue also involves the way macOs asks to explicitly allow access to the folders (I have many hang and crash in Marked 2 with this thing when I move a file from one folder to another) probably there is a lock at this level explaining the endless "processing" issue.

    By the way, even if this complicate a little bit my workflow, I am pleased to found the answer and MANY thanks for your help and reactivity !

    All the best

  7. Support Staff 7 Posted by Brett on 27 Oct, 2020 03:42 PM

    Brett's Avatar

    Glad to hear it. I'm not sure I can fully explain why that would be
    happening, but it sounds like you've found the issue. Thanks for letting
    me know!


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac