Text in Bold type

petere5's Avatar

petere5

13 Oct, 2017 01:13 AM

I'm very new to Marked2. I just opened a text file(BBEdit) and found some of the text had been rendered in bold. Examples from my text are
since
to continue the sage
by the then
and
I could not find any reason for this in Help

  1. Support Staff 1 Posted by Brett on 13 Oct, 2017 04:45 PM

    Brett's Avatar

    Hi,

    I'm uncertain what you mean, exactly. Could you show screen shots and
    attach a sample text document that's causing the behavior?

    It will also save some time if you go to Help->Report an Issue and copy
    the configuration text it provides so I don't have to ask what every
    config option you have set would be.

    -Brett

  2. 2 Posted by petere5 on 13 Oct, 2017 06:13 PM

    petere5's Avatar

    Dear Brett,
    1. Configuration text
    // Please enter a detailed description of the issue
    // Description of the issue:

    // Please enter a list of steps required to reproduce the issue
    // Steps to reproduce:

    1.Produce document in Pages and export to plain text
    2. Open text document in Marked2
    3.

    // If applicable please attach a sample document that causes the issue for you.

    // Configuration (do not edit)
    Marked 2 930 (Direct)
    OS X Version: 10.12.6
    ---
    additionalMathJaxConfig:
    allowPageBreakInCode: 1
    bookTxtIsLeanpub: 0
    summaryMdIsGitBook: 0
    codeIsPoetry: 0
    collapsibleHeadlines: 0
    convertGithubCheckboxes: 1
    convertYAMLToMMD: 0
    defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
    defaultPreviewStyle: swiss
    defaultProcessor: MultiMarkdown
    enableMiniMap: 1
    excludeBlockQuotesFromCounts: 0
    excludeFootnotesFromCounts: 0
    excludeVerbatimFromCounts: 0
    excludeCaptionsFromCounts: 0
    folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
    githubNewlines: 1
    h1IsPageBreak: 0
    h2IsPageBreak: 0
    hrIsPageBreak: 0
    includeMathJax: 0
    limitTextWidth: 0
    minimalJavaScript: 0
    outlineModeExtensions:
    permissionGranted: 0
    printHeaderBottomLeft:
    printHeaderBottomRight:
    printHeaderFooterFirstPage: 0
    printHeaderTopLeft:
    printHeaderTopRight:
    processHTMLFiles: 1
    removeMetadataForPreview: 0
    removeYAMLHeaders: 0
    scrollToEdit: 1
    shouldDetectCritic: 1
    shouldHighlightMarkupErrors: 0
    shouldLoadCritic: 1
    syntaxHighlight: 1

    Text in BBEdit

    A number of years have passed since “Half a Mile in Thirty Years” was published and I have been encouraged to continue the saga up to the time when I finally left the workforce.

      “Half a Mile in Thirty Years” ended when I arrived back in Canberra to take up the appointment of Director General Joint Communications-Electronics. Before proceeding with my adventures in that posting, I thought it worthwhile to retrace my steps and cover a number of side roads which became important in my later years. These include my association with the Duntroon Society and the Venerable Order of the Hospital of St John of Jerusalem.

    Text in Marked2

    Regards, Peter Evans

    Brigadier Peter J A Evans(Retd)
    31/167 La Perouse St,
    RED HILL, ACT 2603
    AUSTRALIA
    Phone +61262395184

  3. Support Staff 3 Posted by Brett on 13 Oct, 2017 06:24 PM

    Brett's Avatar

    Ok, so first question is why you're producing text in pages? Could you attach the actual text file you're getting when you export to "plain text"?

    It appears your text is being placed in a code block, the bolding would be part an attempt at syntax highlighting. I assume it would go away if you turned off Syntax Highlighting in Preferences->Style.

    The second part is that it looks like you have keyword highlighting with passive voice detection turned on. This can be toggled from the Keyword drawer (the small highlighter icon in the lower right or with ⌘⇧K) or you can just toggle highlighting on and off with ⌘⇧H.

  4. 4 Posted by petere5 on 13 Oct, 2017 08:36 PM

    petere5's Avatar

    I usually work with Pages. I converted the Pages text to plain text and opened it with BBEdit and then opened Marked2. I turned off Syntax Highlighting and the bold text returned to Normal.

    I have not previously used a Text Editor for my writing, hence the original work in Pages. In your opinion, is BBEdit a suitable text editor or do you recommend something else?
    Regards, Peter Evans

    Brigadier Peter J A Evans(Retd)
    31/167 La Perouse St,
    RED HILL, ACT 2603
    AUSTRALIA
    Phone +61262395184

  5. Support Staff 5 Posted by Brett on 13 Oct, 2017 08:39 PM

    Brett's Avatar

    BBEdit is great. For writing I usually work in something like
    MultiMarkdown Composer or Byword, but any text editor will do the trick.

    The problem with the export from Pages is probably that it indents your
    paragraphs. In Markdown, that converts them into code blocks, which is
    not what you want. I'd recommend skipping the Pages step entirely.

    -Brett

  6. 6 Posted by petere5 on 13 Oct, 2017 09:39 PM

    petere5's Avatar

    Thanks for your help.
    Regards, Peter Evans

    Brigadier Peter J A Evans(Retd)
    31/167 La Perouse St,
    RED HILL, ACT 2603
    AUSTRALIA
    Phone +61262395184

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac