Rick Farris's Avatar

Rick Farris

02 Jul, 2016 04:42 PM

// Please enter a detailed description of the issue // Description of the issue:

Are tables broken? I can’t get a simple table to export from Ulysses correctly. It seems that your blog post about tables is no longer relevant, but still, it seems like I should be able to Quick Export->Text, Markdown -> Open in -> Marked 2 and get the table rendered, but no joy. what am I doing wrong?

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Quick export
  2. Text, Markdown
  3. Open in -> Marked 2

// If applicable please attach a sample document that causes the issue for you.

| Benefit | San Diego | Sierra Vista |—————————-|—————-|—————- | Family | 0 | 100 | Doctors | 80 | 20 | Living Expenses | 10 | 80

// Configuration (do not edit) Marked 2 922 (Mac App Store)

OS X Version: 10.11.5

allowPageBreakInCode: 1
bookTxtIsLeanpub: 0
codeIsPoetry: 0
collapsibleHeadlines: 0
convertGithubCheckboxes: 1
convertYAMLToMMD: 0
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: swiss
defaultProcessor: MultiMarkdown
enableMiniMap: 0
excludeBlockQuotesFromCounts: 0
excludeFootnotesFromCounts: 0
excludeVerbatimFromCounts: 0
excludeCaptionsFromCounts: 0
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: 1
h1IsPageBreak: 0
h2IsPageBreak: 0
hrIsPageBreak: 0
includeMathJax: 1
limitTextWidth: 0
minimalJavaScript: 0
permissionGranted: 0
printHeaderFooterFirstPage: 0
processHTMLFiles: 1
removeMetadataForPreview: 0
removeYAMLHeaders: 0
scrollToEdit: 1
shouldDetectCritic: 1
shouldHighlightMarkupErrors: 0
shouldLoadCritic: 0
syntaxHighlight: 0

  1. Support Staff 1 Posted by Brett on 02 Jul, 2016 05:08 PM

    Brett's Avatar

    Ulysses escapes the characters in the table, if I recall correctly. If you export Markdown and look at the file, you'll be able to tell exactly what Marked is receiving.


  2. 2 Posted by Rick Farris on 02 Jul, 2016 06:10 PM

    Rick Farris's Avatar

    I found the problem: you can't have "smart dashes" turned on in Ulysses. If smart dashes are turned on (which I think is default) then tables won't render correctly.

    Sorry for the bother.

    -- Rick

  3. 3 Posted by Rick Farris on 03 Jul, 2016 02:48 PM

    Rick Farris's Avatar

    It was the smart dashes that were killing my tables. Turned off the smart
    dashes and now all is well. Thank you!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac