Why does Marked 2 not recognize ordered list created by Ulysses III?

Troy's Avatar


21 Jan, 2015 01:36 AM

I followed the markdown reference to create a nested list in Ulysses III. However, after I clicked *send to Maked 2*, the Marked 2 preview window actually does not recognize the nest list.

Is this a known bug, or is there something wrong with my writing?


  1. Support Staff 1 Posted by Brett on 21 Jan, 2015 06:06 AM

    Brett's Avatar

    Are you specifying Markdown when sending to Marked? Can you show me the
    Markdown that Ulysses is creating for you?


  2. Support Staff 2 Posted by Brett on 21 Jan, 2015 02:24 PM

    Brett's Avatar

    Looking at your screenshot again, assuming it _is_ Markdown that Ulysses
    is sending, it appears that the list is being recognized but the CSS
    style isn't indenting it properly. Is that a custom stylesheet?


  3. 3 Posted by Troy on 21 Jan, 2015 06:30 PM

    Troy 's Avatar


    Yes, I've specifying the Markdown when sending to Marked 2.
    No, it is not a custom stylesheet.

    I kind of figure it out myself.
    If you want to make the **list** looks right in Marked 2, you need to start writing the list after a blank line in Ulysses III.
    Now it looks just as I expect, just see the screen shot.
    Thank you for your help.

  4. Support Staff 4 Posted by Brett on 21 Jan, 2015 07:33 PM

    Brett's Avatar

    Yep, that's what I figured I'd see. Marked, by default, uses
    MultiMarkdown for rendering. MMD requires whitespace between paragraphs
    and lists, lists and code blocks, etc. If this is problematic, you
    should be able to get more consistent results with Ulysses by going to
    Processor preferences and selecting Discount (GFM).


  5. 5 Posted by Vitali Bondar on 24 Apr, 2015 09:20 PM

    Vitali Bondar's Avatar

    Same problem with iA Writer Pro :(

  6. 6 Posted by Vitali Bondar on 24 Apr, 2015 09:28 PM

    Vitali Bondar's Avatar

    pls see screenshot
    and sorry for ugly English ))

  7. Support Staff 7 Posted by Brett on 24 Apr, 2015 09:38 PM

    Brett's Avatar

    You have to have a blank line before the list, as noted above.

  8. 8 Posted by Vitali Bondar on 25 Apr, 2015 11:54 AM

    Vitali Bondar's Avatar

    Got it. Thank you, Bratt.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Screen_Shot_2015-01-20_at_8.25.36_PM.png 699 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac