Strange behavior of list

Michael's Avatar


08 Oct, 2013 04:56 PM

Hello out there,

I am compiling an anatomy test, asking for facts about these four muscles:

M. glutaeus maximus
M. tensor fasciae latae
M. quadriceps femoris
M. pectineus

When I compile this in markdown I get:

1. glutaeus maximus
2. tensor fasciae latae
3. quadriceps femoris
4. pectineus

How can I display the "M."?


PS.: Also, any help on inserting empty lines would be greatly appreciated...

  1. Support Staff 1 Posted by Brett on 08 Oct, 2013 05:03 PM

    Brett's Avatar

    Which version of Marked are you using?

    With the built-in MultiMarkdown processor, you should get something more like:

    M. glutaeus maximus M. tensor fasciae latae M. quadriceps femoris M. pectineus

    All on one row because it doesn't recognize it as a list. Do you have any numbered lists preceding this text?

    You can add line breaks to each line by placing two spaces at the end of each row. Blank lines are always compressed, to add additional empty lines you have to use <br> tags.

  2. 2 Posted by Michael on 08 Oct, 2013 05:09 PM

    Michael's Avatar

    I use the latest, i.e. 2.0 (760). But I realized that I was not using MultiMarkdown but Discount in Behavior/Settings (it compiled my previous document a little nicer...).

    When switching this to MultiMarkdown it works perfectly. But I'm still wondering why the other engine wouldn't handle this correctly...

    Thanks a lot, you are a great help!


  3. Support Staff 3 Posted by Brett on 08 Oct, 2013 05:54 PM

    Brett's Avatar

    Discount has its own way of handling lists, and I believe it recognizes and character with a period after it as a numbered list item.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac