can't disable table-of-contents on print preference (Version 1.3.2 (190))

Keith Irwin's Avatar

Keith Irwin

22 Dec, 2011 08:40 PM

Marked: Version 1.3.2 (190)

I tried out the printTOC (to PDF) and decided I don't really want to use it. So I unchecked the preference option for it, and marked still prints the table of contents when I save-as-pdf.

Checked ~/Library/Preferences/com.brettterpstra.marky.plist and found printTOC set to NO.

Restarted marked several times, created a brand new file as part of my magical-thinking debug methodology (tm), and I still get the TOC when I save to PDF.

printTOC doesn't work at all for html/rtf, which is not surprising because those are exports, while PDF is really a print job.

I'll be happy to upload my pref file if that helps.


  1. Support Staff 1 Posted by Brett on 22 Dec, 2011 08:57 PM

    Brett's Avatar

    Ouch, that's a big bug (I confirmed it on my machine). I'll get a bugfix update out as soon as possible.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac