Line-breaks turn into paragraph-breaks in "copy RTF to clipboard"

Tobi's Avatar


12 Dec, 2014 07:57 PM

As said in our conversation on twitter ( the "copy RTF to clipboard"-function breaks all the line-breaks in my documents.
It seems, as if all the line-breaks turn into paragraph-breaks.

I tried all the different themes, but it seems to affect all of them.

It doesn't seem to be Pages' fault, because it also affects texts in TextEdit.

  1. Support Staff 1 Posted by Brett on 12 Dec, 2014 08:07 PM

    Brett's Avatar

    I'm able to replicate this. I'm not sure why it's happening, though.
    Even if you select all and ⌘C, it loses line breaks. I'll have to look
    into this.

    There is a major update to the RTF engine coming, so this may or may not
    be fixed in the interim.


  2. 2 Posted by Tobi on 12 Dec, 2014 08:15 PM

    Tobi's Avatar

    Ok, thank you for looking into it.
    I can live without it, it's just more work in the formatting-process.

  3. 3 Posted by Gregory on 24 Jan, 2020 01:52 PM

    Gregory's Avatar

    I am seeing a similar problem.

    I format the source text with <br /> tags and the text displays as expected in Marked. however, when I Copy Rich Text, the line breaks are lost.

    are there any settings I can change to fix this?

    Marked v2.5.35 (978)
    OS X 10.15.2 (19C57)

  4. Support Staff 4 Posted by Brett on 24 Jan, 2020 02:01 PM

    Brett's Avatar

    No, unfortunately this is unavoidable in the conversion to rich text.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • B4paCMBCEAA-dy0.png-large.png 714 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac