table not displayed any longer

's Avatar


15 Dec, 2011 03:13 PM

A table I created was displayed correctly with marked a month ago. But now it doesn't any longer. Any ideas?

-- Bert Fitié

  1. Support Staff 1 Posted by Brett on 15 Dec, 2011 03:26 PM

    Brett's Avatar

    It may have to do with an upgrade to the MultiMarkdown processor. Be sure that your syntax looks like:

    header 1 | header 2 | header 3 |  
    | :----- | :------- | :------- |  
    data 1   | data 2   | data3    |

    Note that you need the leading pipe (|) on at least the alignment row. If that doesn't help, post the syntax you're using for the table and I'll see what's up.

  2. 2 Posted by Bert Fitié on 15 Dec, 2011 03:48 PM

    Bert Fitié's Avatar

    I found the cause of the problem. Since SmartyPants transformed some parts of my texts in a way I didn't want, I turned it off in Preferences. I did turn off SmartyPants, but it seems I also turned off the table feature.

    Could you provide for separate preferences, turning off SmartyPants but keeping the full MMD.

    -- Bert Fitié

  3. Support Staff 3 Posted by Brett on 15 Dec, 2011 03:52 PM

    Brett's Avatar

    I think I can, but it will depend on the options the MultiMarkdown executable provides. I'll look into it. Can you post a sample table that causes the issue?

  4. 4 Posted by Bert Fitié on 15 Dec, 2011 04:08 PM

    Bert Fitié's Avatar

    Following simple table, for example, runs fine with the Markdown Compatibity Mode unchecked:

    Collections | #
    ----------- | -:
    All Items | 52
    Secundary Publications | 29
    Ebooks | 4
    Publications | 12
    Publications (2) | 7

    The problem is that with the Markdown Compatibity Mode unchecked I have to "buy in" into SmartyPants, e.g. a isbn like 978-0-07-150273-3 will be displayed as 978–0–07–150273–3 thanks to SmartyPants. This I do not want. So I need the possibility to turn off SmartyPants but to keep all the goodies of MMD

  5. Support Staff 5 Posted by Brett on 15 Dec, 2011 04:26 PM

    Brett's Avatar

    Is the hyphen to mdash conversion the only issue? I'm happy to submit a ticket on MultiMarkdown to ask that it not do that when there are more than one consecutive digit/hyphen pairs, as that doesn't make sense. If you need to disable SmartyPants all together, I did find that I can make that an option. In the meantime, you do have two choices.

    1. You can escape the hyphens with a backslash to avoid them being processed:


      Kind of a pain in the butt, though.

    2. If you have MultiMarkdown installed on its own, you can create a shell script ( with the following contents:

       cat|/usr/local/bin/multimarkdown --nosmart

      Run chmod a+x /path/to/ and set that as the custom processor for Marked

      • If you don't have MultiMarkdown installed, you can do the same with the internal version of multimarkdown:

          cat|/Applications/ --nosmart

    All kind of a pain, so I'll add the option to disable SmartyPants before the next release.

  6. 6 Posted by Bert Fitié on 15 Dec, 2011 07:24 PM

    Bert Fitié's Avatar

    Thanks for the support; I wait for the new release with the option of separate disabling of SmartyPants.

    I'm happy anyway that I know the reason now that my tables were gone: my inadvertent checking of the Markdown Compatibity Mode to get rid of SmartyPants.

    Good luck with further development of

    -- Bert Fitié

  7. Brett closed this discussion on 22 Dec, 2011 12:08 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac