Headers/Footers not appearing in Marked 2.4.4

Simeon Fitch's Avatar

Simeon Fitch

10 Sep, 2014 07:58 PM

I just upgraded to 2.4.4 (850) and when I print, the headers/footers configured in the Export preferences aren't appearing in the generated output. How might I further diagnose this issue?

  1. Support Staff 1 Posted by Brett on 10 Sep, 2014 08:01 PM

    Brett's Avatar

    Build 850 should have fixed this, not broken it. I just tested with
    2.4.4 (850) and headers/footers are working for me in PDF and print
    (they weren't in the initial 2.4 release). So exporting to a paginated
    PDF is not giving you any of your configured headers on a multi-page
    document? And it was working for you previously?

    -Brett

  2. 2 Posted by Simeon Fitch on 10 Sep, 2014 08:11 PM

    Simeon Fitch's Avatar

    I'm not sure which version it /stopped/ working in (I don't always need the feature, and keep up to date as I can), but do know that in the past it /did/ work. I've attached the "About" screen in case that has more details. Any log file I can send you? Using MultiMarkdown mode. No headers/footers from either direct printing nor export to PDF (maybe they are the same inside).

    This was the first update I had to do "manually" due to the MacOS sandboxing hassle. Are there any preferences files I should try removing?

  3. Support Staff 3 Posted by Brett on 10 Sep, 2014 08:38 PM

    Brett's Avatar

    It appears you're running the same version I'm testing with, and based
    on your previous screenshots there should definitely be headers printed.
    Have you tried with multiple documents and gotten the same results?

    One thing to test:

    Put this at the very top of your Markdown file, followed by a blank line
    (or any other metadata):

    Print Header Left: %title

    Then try exporting and see if you get a title in the upper left.

  4. 4 Posted by Simeon Fitch on 10 Sep, 2014 09:02 PM

    Simeon Fitch's Avatar

    I think I figured it out! But it's subtle. Here's the deal:

    If you File->Print... or Command-P, there's not option to turn on the "include headers/footers". So if that switch was set to "off" in the "export to PDF" dialog at some point, you're not going to see headers/footers when going through the native print dialog. If you first do the "Export to PDF" path, turn on header/footer printing, and even click "cancel", it will enable header/footer printing in both places.

    A separate note on the included .md and .pdf file. Note that text partially spans the break between page 1 and page 2. Something to do with calculating header offsets? Mine are set to "20" all around.

  5. Support Staff 5 Posted by Brett on 10 Sep, 2014 09:09 PM

    Brett's Avatar

    I'll take a look at that checkbox. Thanks for the heads up.

    The broken text lines are a problem I was just pulling hair out over. I
    found that if I set my top margin to 20 and bottom to 10, it wasn't
    happening. But it's supposed to account for that, so I need to look
    deeper into it. Will do that asap.

    -Brett

  6. 6 Posted by Mike Tassano on 07 Oct, 2018 10:54 PM

    Mike Tassano's Avatar

    Still not working in 2.5.26 until Export PDF Paginated, clicking the "include Headers" box.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2014-09-10_at_3.57.49_PM.png 131 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac