inline footnotes not working in marked 2

David Botton's Avatar

David Botton

28 Jul, 2014 07:03 PM

Your documentation says:
"In more recent versions of MultiMarkdown (like the one built into Marked), you can create footnotes inline using text(*footnote text*) syntax. Note that this will not be compatible with other processors or older versions of MultiMarkdown."

This does not work when I type:
This is another test(*I really want this to work*)

Please help, I really need this feature. Thanks!

  1. Support Staff 1 Posted by Brett on 28 Jul, 2014 07:09 PM

    Brett's Avatar

    Which page of the docs is that on? It's not correct. The syntax should
    be:

    Text[^footnote text]

    If there's more than one word in the footnote brackets, it becomes a
    full footnote instead of a title reference.

    -Brett

  2. 2 Posted by David Botton on 29 Jul, 2014 04:35 AM

    David Botton's Avatar

    It is from the help menu -> Markdown Guide -> MultiMarkdown

    That worked. Thank you.

    Is there a way to have Marked refresh the clipboard preview everytime marked gets the focus? That would be a big help for when I am using evernote instead of scrivener.

    Thanks
    David Botton

  3. Support Staff 3 Posted by Brett on 29 Jul, 2014 02:56 PM

    Brett's Avatar

    Thanks I'll update that doc.

    I don't see any practical way to implement "refresh on focus" from a
    usability point of view. I'll think about it, but Command-Tab, Command-R
    is probably your best bet there. Marked does have a url handler that you
    can implement in a script:

    refresh all windows: marked://refresh
    refresh a named document (can use a partial title):
    marked://refresh/filename

    This will be changing in the next version so that /refresh refreshes
    just the frontmost window, and /refresh/all refreshes everything. I
    don't know if this is useful in your case, but it's available.

  4. 4 Posted by David Botton on 29 Jul, 2014 05:13 PM

    David Botton's Avatar

    Command-R doesn't work for the "clipboard preview" window, would be an improvement if it did.

    Currently I have to - Copy my content in evernote, switch to marked, close the old 'clipboard preview', then hit shift - command - Y

    A Command-R would remove one step if it worked.

    An on focus refresh from pasteboard would replace 2 steps.

    The idea would be that this type of persistent window is either a different type say 'refreshing clipboard preview' or some sort of option. Even better if it could hook the pasteboard event, but not sure that is possible.

    David Botton

  5. Support Staff 5 Posted by Brett on 29 Jul, 2014 06:37 PM

    Brett's Avatar

    You're correct on ⌘R, forgot about that case. The problem with refresh
    on focus is that you have no control, and if you've copied anything else
    and happen to focus the document, poof, gone. Hitting ⌘R (or a less
    likely shortcut) to refresh from clipboard is an option that I'd
    consider.

  6. 6 Posted by lucb on 22 Nov, 2018 08:23 PM

    lucb's Avatar

    This isn't working in my instance of Version 2.5.27 (964). I do have MultiMarkdown enabled. Other functions are working (e.g., table of contents and links).

    I've tried these together and in isolation:

    Here is some text containing a footnote.[^somesamplefootnote]

    Here is another footnote.[^This is the footnote itself]

    Footnotes

    [^somesamplefootnote]: Here is the text of the footnote itself.

  7. Support Staff 7 Posted by Brett on 23 Nov, 2018 01:41 PM

    Brett's Avatar

    Your test text works fine for me here. Are you certain you don't have a
    custom processor enabled?

    Thanks,
    Brett

  8. 8 Posted by lucb on 23 Nov, 2018 05:33 PM

    lucb's Avatar

    Not to my knowledge. I've enclosed a zip containing:
    - Marked - Processor - LPB .png
    - Marked - Advance - LPB.png

    I can work around this by inserting footnote markers with this via TextExpander [[N]](#fnN)

    and then:
    # Footnotes
    <span id="fnN"></span>
    **N**

    where I manually replace N

  9. Support Staff 9 Posted by Brett on 23 Nov, 2018 05:42 PM

    Brett's Avatar

    You should definitely not need such an elaborate workaround for
    something that's a default capability. Could you also attach a sample
    document with your footnotes so I can verify that the syntax is correct?

    Thanks,
    Brett

  10. 10 Posted by lucb on 23 Nov, 2018 05:50 PM

    lucb's Avatar

    Here it is.

  11. Support Staff 11 Posted by Brett on 23 Nov, 2018 06:32 PM

    Brett's Avatar

    Using the same settings that you showed me, the file above displays as:

    I'm honestly not certain what could be going wrong. It's possible that somehow a preference was corrupted and it's not actually using MultiMarkdown. You might try switching to the GFM processor, refreshing, then switching back to see if it makes a difference. Let me know if that helps.

    Thanks,
    Brett

  12. 12 Posted by lucb on 23 Nov, 2018 07:06 PM

    lucb's Avatar

    When I switched to GFM, this type of footnote is indeed treated as a footnote: [^somesamplefootnote]. But not this type: [^This is the footnote itself] . That's OK, I don't need the latter type, and perhaps it's not even supposed to be understood by GFM.

    When I switched back to MultiMarkdown, I got the same results as I first reported, alas.

    That's OK. I have a long track record of uncovering all kinds of weird issues in OS's and applications (perhaps I should have gone into QA!). This must have something to do with my setup (maybe I once installed some markdown libraries that are being picked up in a path variable or something? ), otherwise others would be reporting it.

    I'll try using GFM (which I didn't know about before).

    When I blog, I write my footnotes manually (per above) -- I don't think my WordPress plugin handles footnotes. My current document is, in contrast, a long academic doc.

  13. Support Staff 13 Posted by Brett on 24 Nov, 2018 02:28 PM

    Brett's Avatar

    It's so odd that inline footnotes aren't working for you under MMD. It's
    a default behavior for the version of MMD that's embedded (and no, the
    processor is hardcoded into Marked, it can't be picking up any other
    version from your system). I'm at a loss on this one.

    If you haven't used GFM (GitHub Flavored Markdown) before, check the
    Help->MultiMarkdown Reference for the differences. They're actually
    pretty minor at this point, especially now that MMD handles fenced code
    blocks. The biggest difference is what it _doesn't_ support. Things like
    ABBR, definition lists, etc. For normal Markdown, tables, footnotes,
    etc. it's great, though.

    Most of the WordPress Markdown plugins do support footnotes (they use
    PHP Markdown Extra), though I'm not certain the Jetpack version does.

    -Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac