Marked not tracking current page in voodoopad

Richard Kerr's Avatar

Richard Kerr

18 May, 2014 10:43 AM

Hi,
I just purchased Marked 2 but it wont track the current open page in Voodoopad. It's just sits on the first page that is opened.
Any thoughts?

  1. 1 Posted by Richard Kerr on 18 May, 2014 10:51 AM

    Richard Kerr's Avatar

    It works ok if I press command R and do a manual refresh but it isn't automatic.

  2. Support Staff 2 Posted by Brett on 18 May, 2014 11:27 AM

    Brett's Avatar

    Marked can't tell when you switch pages or tabs, only when a file
    changes. If you hit ⌘S in VoodooPad, you should see an update.

  3. 3 Posted by Lorenzo Lutjens on 04 Jul, 2015 12:19 PM

    Lorenzo Lutjens's Avatar

    Hi,

    I'm having a similar issue wit VoodooPad. I downloaded the trial version of Marked 2 and could preview the open vpdoc in Marked 2. After I downloaded the version bought through the AppStore I now can't see any preview. Marked 2 simply tells me:

    there is no content. The document must be open and in the foreground in VoodooPad to preview.

    Though the document is open and in the foreground. I do a Refresh, but nothing happens.
    I have tried again through the trial app (now it won't open, because trial has expired) but the result is the same. I have reinstalled the app but no result either.

    Any thoughts?

    Thanks!

  4. Support Staff 4 Posted by Brett on 04 Jul, 2015 12:49 PM

    Brett's Avatar

    Which version of VoodooPad are you running?

    I'm not seeing any issue with Marked v2.4.11 on my end. Could you try
    opening Console.app (in the /Application/Utilities folder) and seeing if
    there are any Marked 2 messages appearing under "All Messages" when you
    refresh an open VP document in Marked?

    Also, are you having any issues with previewing a regular Markdown file?

    -Brett

  5. 5 Posted by Lorenzo Lutjens on 04 Jul, 2015 01:09 PM

    Lorenzo Lutjens's Avatar

    Hi,

    I'm using the last version of VoodoPad: 5.1.3.

    I've tried with several documents I have on VoodooPad and the same result. This is the message I got from the Console log:

    4/7/15 13:56:09,470 Marked 2[1311]: {
        NSAppleScriptErrorBriefMessage = "Expected \U201c,\U201d or \U201c)\U201d but found identifier.";
        NSAppleScriptErrorMessage = "Expected \U201c,\U201d or \U201c)\U201d but found identifier.";
        NSAppleScriptErrorNumber = "-2741";
        NSAppleScriptErrorRange = "NSRange: {61, 4}";
    }
    

    When I do "Export page as…" from VoodooPad one page as text with Markdown format, I can preview that page on Marked.

    Thanks!

    Lorenzo

  6. Support Staff 6 Posted by Brett on 04 Jul, 2015 01:19 PM

    Brett's Avatar

    Ok, it looks like it's having trouble with some characters in your
    document. Can you show me the text from one page of your VPDoc that I
    can test with?

  7. 7 Posted by Lorenzo Lutjens on 04 Jul, 2015 01:32 PM

    Lorenzo Lutjens's Avatar

    How should I show it to you? Copy&Paste? Send an export from VP?

  8. Support Staff 8 Posted by Brett on 04 Jul, 2015 03:03 PM

    Brett's Avatar

    Actually, if you could, create a new voodoopad doc, paste in a couple of pages and save it. Then compress it by right clicking it in Finder and choosing "Compress…" and attach it to a reply here.

    If easier and ok with you, feel free to just attach the whole vp doc you're working with.

    - Brett

  9. 9 Posted by Jeff on 04 Jul, 2015 08:38 PM

    Jeff's Avatar

    I am seeing the same behavior in Marked2 Version 2.4.11 (895).

    I edit my engineering notes files in emacs with a Marked2 pane side by side. The preview update functionality works only some of the time -- I would estimate < 50% of the time for me.

    I went back to Marked, which does not show the issue.

  10. Support Staff 10 Posted by Brett on 04 Jul, 2015 08:54 PM

    Brett's Avatar

    @jeff, a sample of a non-working document would be helpful.

    Thanks,
    Brett

  11. Support Staff 11 Posted by Brett on 04 Jul, 2015 08:55 PM

    Brett's Avatar

    You also need to keep in mind that simply switching pages does not modify the document file, so Marked receives no notification of an update. An edit and/or save must take place to register a refresh in Marked.

  12. 12 Posted by Jeff on 04 Jul, 2015 09:02 PM

    Jeff's Avatar

    Hi Brett.

    Yes, I am saving the file. I am a long-time Marked and now hopefully Marked2 user. I cannot simply post the file; it is all about my work, which is not public.

    I had hoped to see some log messages in Console, as Richard did, but I do not see any.

    Is there a some way to turn up logging that Marked2 does to try to track this down?

  13. Support Staff 13 Posted by Brett on 04 Jul, 2015 09:08 PM

    Brett's Avatar

    Jeff,

    You can enable debug mode in advanced prefs, which will output more to the log.

    Is it possible for you to create a scratch document that can replicate the issue?

  14. 14 Posted by Jeff on 04 Jul, 2015 09:34 PM

    Jeff's Avatar

    Ok, attached please find a short file that shows the issue, and a screenshot of what I see on my machine.

  15. 15 Posted by Lorenzo on 04 Jul, 2015 09:46 PM

    Lorenzo's Avatar

    Hi Brett,

    I'm attaching a VoodooPad test file with has the same issues with the preview on Marked.

    Tracking back what I did today I noticed two things:

    • I updated today my VoodooApp to 5.1.3. (I was already working on version 5.1.x). I think that after the update I couldn't get the preview of the files.
    • Checking the log of the console I found also some errors related to VoodooPad and Marked 2 reported by 'kernel: sandbox:' "deny file-read-data". I copy one of them in case it has something to do:
    Marked 2(1096) deny file-read-data /Volumes/Data/Users/llutjens/Applications/VoodooPad.app
    
    Process:         Marked 2 [1096]
    Path:            /Applications/Marked 2.app/Contents/MacOS/Marked 2
    Load Address:    0x10ff03000
    Identifier:      com.brettterpstra.marked2
    Version:         895 (2.4.11)
    Code Type:       x86_64 (Native)
    Parent Process:  launchd [1]
    
    Date/Time:       2015-07-04 13:11:33.752 +0100
    OS Version:      Mac OS X 10.10.4 (14E46)
    Report Version:  8
    
    Thread 0:
    0   libsystem_kernel.dylib          0x00007fff85ba7012 __open_nocancel + 10
    1   CoreFoundation                  0x00007fff86d488ba _CFIterateDirectory + 74
    2   CoreFoundation                  0x00007fff86d48084 _CFBundleGetBundleVersionForURL + 468
    3   CoreFoundation                  0x00007fff86d471b5 _CFBundleCreate + 213
    4   AppleScript                     0x0000000116ae52c9 openresfile_t::openresfile_t(FSRef const*, bool) + 193
    5   AppleScript                     0x0000000116a9a010 GetAppTerminology(TUASApplication const*, __CFURL const*) + 156
    6   AppleScript                     0x0000000116aa5d81 TUASApplication::Terminology() const + 117
    7   AppleScript                     0x0000000116a928b7 UASStartTellScope1(TUASCommand*) + 565
    8   AppleScript                     0x0000000116a82f6b _ReductionProc_ + 653
    9   AppleScript                     0x0000000116a93144 TASParser::Parse(TTerminology*, TUASValue*, char const*, unsigned long) + 1274
    10  AppleScript                     0x0000000116a7a6e0 ASCompile(AEDesc const*, int, unsigned int*) + 451
    11  AppleScript                     0x0000000116a74aad AppleScriptComponent + 737
    12  AppleScript                     0x0000000116a8ff83 AGenericCall::Delegate(ComponentInstanceRecord*) + 37
    13  AppleScript                     0x0000000116a8ff3f AGenericManager::HandleOSACall(ComponentParameters*) + 55
    14  AppleScript                     0x0000000116a8f564 GenericComponent + 108
    15  OpenScripting                   0x00007fff8323efd3 OSACompile + 57
    16  Foundation                      0x00007fff82ff0c04 -[NSAppleScript compileAndReturnError:] + 146
    17  Foundation                      0x00007fff82ff0edf -[NSAppleScript(NSPrivate) _executeWithMode:andReturnError:] + 68
    18  Marked 2                        0x000000010ff1444c
    19  Marked 2                        0x000000010ff1a1a8
    20  libdispatch.dylib               0x00007fff82cbc323 _dispatch_call_block_and_release + 12
    21  libdispatch.dylib               0x00007fff82cb7c13 _dispatch_client_callout + 8
    22  libdispatch.dylib               0x00007fff82cc3cbf _dispatch_main_queue_callback_4CF + 861
    23  CoreFoundation                  0x00007fff86dde3f9 __CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE__ + 9
    24  CoreFoundation                  0x00007fff86d9968f __CFRunLoopRun + 2159
    25  CoreFoundation                  0x00007fff86d98bd8 CFRunLoopRunSpecific + 296
    26  HIToolbox                       0x00007fff8682456f RunCurrentEventLoopInMode + 235
    27  HIToolbox                       0x00007fff868242ea ReceiveNextEventCommon + 431
    28  HIToolbox                       0x00007fff8682412b _BlockUntilNextEventMatchingListInModeWithFilter + 71
    29  AppKit                          0x00007fff84ac58ab _DPSNextEvent + 978
    30  AppKit                          0x00007fff84ac4e58 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 346
    31  AppKit                          0x00007fff84abaaf3 -[NSApplication run] + 594
    32  AppKit                          0x00007fff84a37244 NSApplicationMain + 1832
    33  Marked 2                        0x000000010ff04e84
    
    Binary Images:
           0x10ff03000 -        0x110031fff  com.brettterpstra.marked2 (2.4.11 - 895) <d9612600-79e6-365d-84f2-6572274294cf> /Applications/Marked 2.app/Contents/MacOS/Marked 2
           0x116a73000 -        0x116afcffb  com.apple.applescript (2.4 - 368.1) <4fafb0d5-6b4b-3abe-ad78-353921059251> /System/Library/PrivateFrameworks/AppleScript.framework/Versions/A/AppleScript
        0x7fff82cb6000 -     0x7fff82ce0ff7  libdispatch.dylib (442.1.4) <502cf32b-669b-3709-8862-08188225e4f0> /usr/lib/system/libdispatch.dylib
        0x7fff82ee2000 -     0x7fff83213fff  com.apple.Foundation (6.9 - 1153.20) <f0ff3a5d-c5b7-34a1-9319-de1ef928e58e> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
        0x7fff8322e000 -     0x7fff83247ff3  com.apple.openscripting (1.6.4) <bf79207b-c762-346d-8ff0-3ddcecc9e9e2> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
        0x7fff84a34000 -     0x7fff855b5ff7  com.apple.AppKit (6.9 - 1348.17) <e485d56d-3e72-34b7-99bb-bfdee2d07bf5> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
        0x7fff85b91000 -     0x7fff85baefff  libsystem_kernel.dylib (2782.30.5) <101d28c0-af07-3b81-87be-ca27aded33ab> /usr/lib/system/libsystem_kernel.dylib
        0x7fff867f2000 -     0x7fff86af7ff3  com.apple.HIToolbox (2.1.1) <083019eb-7f58-36f1-bf7f-9e746f692e5c> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
        0x7fff86d27000 -     0x7fff870bfff7  com.apple.CoreFoundation (6.9 - 1153.18) <5c0892b8-9691-341f-9279-ca3a74d59aa0> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
     ```
    
  16. Support Staff 16 Posted by Brett on 05 Jul, 2015 12:23 PM

    Brett's Avatar

    Jeff, this thread is about VoodooPad documents, so I'm not completely
    sure what issue you're seeing. Update functionality is working fine for
    me on your document. Do you have "scroll to edit" enabled in
    preferences?

  17. Support Staff 17 Posted by Brett on 05 Jul, 2015 12:27 PM

    Brett's Avatar

    Lorenzo, I assume you're using the Mac App Store version? Try opening preferences, and then under the advanced tab click the "Update Permissions" button. After granting full disk access, see if you have any different results.

    Thanks,
    Brett

  18. 18 Posted by Lorenzo on 05 Jul, 2015 04:07 PM

    Lorenzo's Avatar

    OK! It works. After updating the permissions in the preferences tab, all the documents in VoodooPad are now correctly previewed in Marked.

    Thanks for the assistance!

    Lorenzo

  19. Support Staff 19 Posted by Brett on 05 Jul, 2015 04:59 PM

    Brett's Avatar

    Sure thing!

  20. 20 Posted by frixjk on 01 Mar, 2016 08:36 AM

    frixjk's Avatar

    Ciao,
    I use the cgus plugin to show in Marked 2 the active page I am writing in VoodooPad. It works fine.
    I'm wondering if there is it a way to to associate a keybord-shortcut for that plugin. And if yes (as I hope!) how can I associate to it?
    (Sorry but I am not a programmer)

    Thanx in advance

  21. 21 Posted by frixjk on 01 Mar, 2016 11:35 AM

    frixjk's Avatar

    I added, at the start of a copy ofthe original plug-in, this:

    /* VPLanguage = jstalk
    VPScriptMenuTitle = Edit Page in Marked-SCut
    VPShortcutKey = 9
    VPShortcutMask = command control
    VPEndConfig
    /*

    The new name is: Edit Page in Marked-SCut
    the key for shortcut is: 9

    It seems to work.
    ...But, could somebody tells me if it is really correct?

  22. Support Staff 22 Posted by Brett on 01 Mar, 2016 12:37 PM

    Brett's Avatar

    I've not worked with JSTalk plugins, but you can just drag a voodoo pad project to the Marked icon and it will automatically show the current page when you edit…

    -Brett

  23. 23 Posted by frixjk on 01 Mar, 2016 01:24 PM

    frixjk's Avatar

    @-Brett: True.

    My goal (in VoodooPad) is to use mmd -- displayed by Marked 2-- as I use TexShop with his preview (cmd+t): without the mouse for compiling.
    The Gus's plugin is great but it comes without keyboard shortcut. So I think of create one by myself.

    Federico

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac