CriticMarkup proofing not working

Enzonen's Avatar

Enzonen

12 Aug, 2022 01:14 PM

Writing in Atom, using CriticMarkup (for instance: {~~hipsum~>ipsum~~}), within a md-file:

1: checkbox 'Enable CriticMarkUp automatically ..' checked: No content is shown, except for the three Critic Markup Buttons.
2. checkbox unchecked: Content is visible (of course not the buttons for critic markup)
3. With content visible, toggle the option from the Marked2 Menu: Proofing > Process Critic markup. Content disappears. As in display: none?

Is it a known bug? Or am I missing a crucial part of the magic?

  1. Support Staff 1 Posted by Brett on 12 Aug, 2022 02:17 PM

    Brett's Avatar

    It requires python, which is no longer included with macOS. You may be able to solve the issue by installing the Command Line Tools package from Apple. When I get back to my machine I'll add a link to this thread.

  2. 2 Posted by Enzonen on 13 Aug, 2022 04:22 PM

    Enzonen's Avatar

    I think Python is installed: python3 --version at the command line responds with Python 3.9.13. It is installed at: /usr/local/bin/python3

  3. 3 Posted by jarnleikr on 27 Sep, 2022 02:46 AM

    jarnleikr's Avatar

    I have the same problem, and I also have python installed (3.9.12).

    There is definitely something odd going on. I have turned on "Enable CriticMarkup" in the preferences and the three tabs (markup, original and edited) does not show up.
    So I try and turn on Quick Toggles -> CriticMarkup Always, and still no tabs.

    But when I turn off Quick Toggles -> CriticMarkup Always the three tabs show up.
    However CriticMarkup is still not recognised.

    Furthermore if I toggle Quick Toggles -> CriticMarkup Always and/or enable/disable CriticMarkup in the preferences (yes, with refresh), the three tabs will not disappear.
    And still CriticMarkup is not recognised.

    But if I restart Marked then the three tabs disappear despite CriticMarkup being enabled in the preferences and Quick Toggles -> CriticMarkup Always checked.

    And again the only way to show the three tabs is to uncheck Quick Toggles -> CriticMarkup Always.

    And as I said no CriticMarkup recognition in any configurations...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac