App crashes after custom processor config with pandoc

jla.embrechts's Avatar


06 Feb, 2022 01:07 PM


First of all, I really like this app and I have been using it for years. Unfortunately today the app keeps on crashing after configuration of a custom processor with pandoc. I have tried to manually remove the presences file in /Library/Application Scripts/com.brettterpstra.marked2 and removing the app. But after re-installation it still crashes.

I think it is the custom processor that crashes the app. However:
- I selected a valid pandoc installation - I used: -f markdown -t html5 --bibliography=Users/mybibliography.bib --smart --normalize -s

How can I change the preferences (deactivate the processor) outside of the app or how can I resolve this problem in another way?

Thanks in advance,


  1. Support Staff 1 Posted by Brett on 06 Feb, 2022 03:44 PM

    Brett's Avatar

    The preference file you need to delete varies based on which version you're using (Mac App Store, Paddle, or Setapp). If you're using the direct purchase version (Paddle) it would be located at ~/Library/Preferences/com.brettterpstra.marked2.plist. Let me know if you're using a different version.

    An alternate solution is to launch "fresh". If the crash is occurring because of a bad custom processor and a Markdown file is attempting to restore on every launch, you can stop the file restore by opening Terminal and running `open -Fa Marked\`. If this allows the app to launch, you'll then be able to manually edit the custom processor.

    Your custom processor arguments need an absolute path to a bib file, meaning it should start with a forward slash. Also, remove the -s, as that will break Marked's rendering. Beyond that, if the command works on the command line, it shouldn't be crashing the app.


  2. 2 Posted by jla.embrechts on 06 Feb, 2022 04:21 PM

    jla.embrechts's Avatar

    Dear Brett,

    Thank you for the quick reply, the -Fa prefix helped me getting to the preferences pane. Currently it still crashes with the processor, but when I disable it it works just fine.

    This were the arguments i used for the pandoc processor: -f markdown -t -html5 --bibliography=/Users/jurrienembrechts/Documents/KNO/Onderzoek/Sourcefiles/zotero_export.bib --smart —normalize

    If you have any advice concerning this it would really help me, otherwise I’ll just keep on trying.

    Kind regards,


  3. Support Staff 3 Posted by Brett on 06 Feb, 2022 04:23 PM

    Brett's Avatar

    What do you have for the executable of the processor?


  4. 4 Posted by jla.embrechts on 06 Feb, 2022 04:25 PM

    jla.embrechts's Avatar


    I just noticed that it works with args: -f markdown -t -html5

    I just would like to ad citations and a reference list

  5. Support Staff 5 Posted by Brett on 06 Feb, 2022 04:28 PM

    Brett's Avatar

    What happens if you add the bibliography option but leave off normalize?


  6. 6 Posted by jla.embrechts on 06 Feb, 2022 04:33 PM

    jla.embrechts's Avatar

    It crashes again… with bibliography

  7. Support Staff 7 Posted by Brett on 06 Feb, 2022 06:01 PM

    Brett's Avatar

    Can you verify that the same command (including bibliography with absolute path) works from the command line?


  8. 8 Posted by Arek on 11 May, 2022 11:30 AM

    Arek's Avatar

    I have the same problem, i.e. Marked2 doesn't preview bibliographic informations.
    Path: /usr/local/bin/pandoc
    Args: -f markdown -t html --bibliography=/Users/szlaga/TBXConfig/Library.bib --csl=/Users/szlaga/TBXConfig/apa.csl

    Tinderbox preview options works fine with these settings, only Marked 2 doesn't show my citations.

  9. Support Staff 9 Posted by Brett on 11 May, 2022 01:46 PM

    Brett's Avatar

    @Arek, they work in Tinderbox, but do they work on the command line? I assume so as I don't see anything wrong with your arguments, but please verify.

    i can't do a lot of Pandoc support here, it's not my product, but I know enough people have gotten bib/cit working that it can be done.

  10. 10 Posted by jla.embrechts on 23 May, 2022 09:52 AM

    jla.embrechts's Avatar

    Dear Brett,

    Unfortunately I have not been able to use the Marked 2 app anymore.
    The app currently doesn’t display text anymore and just leaves a white screen. It does still count words but I can’t see nor select them and it isn’t a (css) styling problem.
    Could you please advise me how to fix this or how to do a full uninstall.

    Kind regards,


  11. Support Staff 11 Posted by Brett on 23 May, 2022 12:24 PM

    Brett's Avatar


    The issue you're seeing is one that's happening with CriticMarkup for some customers. I haven't solved it yet. You can see the troubleshooting so far here:

  12. 12 Posted by jla.embrechts on 23 May, 2022 08:43 PM

    jla.embrechts's Avatar

    Thank you Brett,

    I also have criticmarkup so it probrably is the same issue. I will keep following the discussion.



Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac