marked displaying text in narrow column that is 'released' if I turn off Enable Custom Processor

skiptime's Avatar


22 Jun, 2021 04:09 PM

When I open a document the text displays in a narrow column (regardless of which style is selected). This column is 'released' if I turn off Enable Custom Processor and refresh. The column (or page width) is then restricted again if I open the document again. This is a new issue and happens across multiple documents.

Here's the scenario in action:

// Configuration Marked 2 1022 (Direct)

macOS Version: 11.4

allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: NO
collapsibleHeadlines: NO
convertGithubCheckboxes: YES
convertGithubEmoji: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 107
defaultProcessor: MultiMarkdown
enableMiniMap: NO
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: NO
includeKatex: NO
limitTextWidth: YES
mathNumberEquations: NO
mathNumberEquationsSide: 0
mathNumberEquationsAMSOnly: NO
minimalJavaScript: NO
permissionGranted: NO
printHeaderFirstPage: NO
printFooterFirstPage: NO
processHTMLFiles: YES
removeMetadataForPreview: NO
removeYAMLHeaders: YES
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: NO
shouldLoadCritic: NO
syntaxHighlight: NO
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: YES
customMarkdownProcessor: /usr/local/bin/pandoc
useCustomPreprocessor: NO
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 22 Jun, 2021 04:57 PM

    Brett's Avatar

    A few things to check. First, what arguments are you sending to Pandoc?

    Second, I note in your settings that you have "Limit text width in
    Preview" turned on in Style Preferences. That shouldn't have a different
    effect when the custom processor is on vs off, but disable that for now
    while we figure out what's going on.

    Lastly, when the document is displaying in the narrow column, save it to
    HTML (⌘S). Attach that HTML file to this conversation so I can see
    exactly what Pandoc is outputting.


  2. 2 Posted by skiptime on 22 Jun, 2021 05:40 PM

    skiptime's Avatar

    Thanks Brett.

    1. -f markdown+smart -t html5 --bibliography=/Users/xxxx/Dropbox/ske-library3.bib -s --csl=/Users/xxxx/Dropbox/pandoc/chicago-note-bibliography-16th-edition.csl

    2. Turned off (no difference) -- forgot to say that I'd tried this.

    3. Attached (with most of text cut). Note that Marked is not rendering the citations correctly either -- but is with other documents.

    Cheers, Simon.

  3. Support Staff 3 Posted by Brett on 22 Jun, 2021 09:02 PM

    Brett's Avatar

    Can I see the markdown document you generated that HTML from? There's a
    document within a document in the HTML export, and if your original
    document contains HTML markup already, that's definitely going to cause
    some weirdness.


  4. Support Staff 4 Posted by Brett on 22 Jun, 2021 09:52 PM

    Brett's Avatar

    Oh, I see the issue. Remove the `-s` flag from your arguments. That
    tells pandoc to create a "standalone" document, meaning it has the
    head/body tags. We don't want that, Marked provides all of that, we just
    want pandoc to fill in the middle.


  5. 5 Posted by skiptime on 23 Jun, 2021 08:04 AM

    skiptime's Avatar

    Thanks Brett. That's fixed the column width issue. Much obliged.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac