Error opening Pandoc

Maurizio Passariello's Avatar

Maurizio Passariello

13 May, 2021 11:45 PM

Error running custom processor
pandoc: pandoc: openBinaryFile: does not exist (No such file or directory)

Hi,

I get this message when I try to convert a md file. I have attached my setting. Could you tell me what I'm doing wrong?

  1. 1 Posted by Maurizio Passar... on 14 May, 2021 10:06 AM

    Maurizio Passariello's Avatar

    Based on some previous discussions I have also tried:

    --from=markdown --to=html --bibliography=/Users/maurizio/Zotero/My Library.bib -s --citeproc

    But still I get the error (attached) and my references are not rendered.
    I also tried to put my bib file path in the YAML header. But again no success...Can anyone help please??

  2. 2 Posted by Maurizio Passar... on 14 May, 2021 10:08 AM

    Maurizio Passariello's Avatar

    Hopefully creenshot attached this time

  3. Support Staff 3 Posted by Brett on 14 May, 2021 03:14 PM

    Brett's Avatar

    The second attempt looks more correct than what's in the screenshot. You may need to escape or quote the path to the bib file if it contains spaces:

    --from=markdown --to=html --bibliography=/Users/maurizio/Zotero/My\ Library.bib -s --citeproc
    

    Note the backslash in My\ Library.

    Let me know if that helps.

  4. 4 Posted by Maurizio Passar... on 14 May, 2021 03:44 PM

    Maurizio Passariello's Avatar

    Thanks Brett, that works!

  5. Support Staff 5 Posted by Brett on 14 May, 2021 03:50 PM

    Brett's Avatar

    Glad to hear it :).

    Thanks,
    Brett

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac