Doesn't work "Additional CSS"

Masanori Kado's Avatar

Masanori Kado

11 May, 2021 08:20 AM

When clicking "Additional CSS:" - "Edit CSS" button, Marked2 is going to freeze.

Activity Monitor says:

Marked2(Not Responding) Heaviest stack for the main thread of the target process:

I'm using "Version 2.6.8 (1021)" on Mac OS 10.15.7 (19H1030)

  1. Support Staff 1 Posted by Brett on 11 May, 2021 03:56 PM

    Brett's Avatar

    H Masanori,

    Are you using the Mac App Store version, or the Paddle (direct purchase)
    or Setapp version?


  2. 2 Posted by Masanori Kado on 11 May, 2021 04:53 PM

    Masanori Kado's Avatar

    Direct Purchase ver.

  3. Support Staff 3 Posted by Brett on 11 May, 2021 05:36 PM

    Brett's Avatar

    I’ve seen this pop up once or twice before, and the solution has
    usually been to delete preferences and start clean. Something seems to
    get corrupted, though I haven’t narrowed down exactly where it happens
    yet. This unfortunately will delete your custom settings and you’ll
    have to add any Custom Styles again, but hopefully it will clear up the

    To delete your preferences with the direct (non-MAS) version of Marked

    1. Quit Marked 2
    2. Delete the file at
    ~/Library/Preferences/com.brettterpstra.marked2.plist (and any other
    files starting with com.brettterpstra.marked2). If you're not sure how
    to access this folder, open Finder and press ⌘⇧G, then paste
    "~/Library/Preferences" (without quotes) into the box.
    3. Reboot the computer (this is important as macOS aggressively caches
    preferences and may just restore the deleted file without your
    4. Launch Marked 2


  4. 4 Posted by Masanori Kado on 12 May, 2021 02:53 PM

    Masanori Kado's Avatar

    Thank you. It works. But after a few tries, the problem happened again. I think there is something wrong with this feature.

  5. Support Staff 5 Posted by Brett on 12 May, 2021 05:21 PM

    Brett's Avatar

    Are you putting any text into the field before it gets stuck, or is it
    hanging even if it's empty?


  6. 6 Posted by Gustavo Bezerra on 09 Dec, 2021 05:19 AM

    Gustavo Bezerra's Avatar

    I ran into the exact same issue today for the first time.
    Deleting com.brettterpstra.marked2.plist solved the issue. No reboot was necessary.
    Not sure if relevant, but this was the first time I am using Marked 2 since upgrading to macOS Monterey

    OS: macOS 12.0.1
    Marked: 2.6.13 (1027)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac