Custom styles from the Style Gallery fail to install with Install button

laurentstawski's Avatar


28 Apr, 2021 02:43 PM

This comment was split from the discussion: Marked 2 not a Universal Binary (Apple Silicon)

Here are the steps I followed:
1.Marketed launch
2.on Safari:
3.theme selection (here Bear): on install and not on CSS
5. reply with "allow" to the message that appears: Would you like to allow this page to open "Marked"?
6. Marked then opens to preferences and the "style" tab

Then nothing happens and the theme is not installed.

  1. Support Staff 1 Posted by Brett on 28 Apr, 2021 02:44 PM

    Brett's Avatar

    Splitting this off into a new issue:

    It shouldn't be opening preferences at all, so that's odd. But Bear isn't in the list of custom styles after Marked activates?

    Do you have preferences open prior to clicking the link? If preferences are closed, do they still open?

    Does the same thing (Preferences opening) happen when clicking the link from Firefox?


  2. 2 Posted by laurentstawski on 28 Apr, 2021 03:37 PM

    laurentstawski's Avatar

    I left Marked and then repeated the operation with three browsers (safari, firefox and edge). Still no results. Do I have to restart the Macbook?

  3. Support Staff 3 Posted by Brett on 28 Apr, 2021 04:46 PM

    Brett's Avatar

    It's never a bad troubleshooting step to reboot, but I don't expect it to fix whatever is going on. Worth starting with, though.

    You're not the first person to mention this, but I've never been able to reproduce it. If I recall correctly, the last time I heard about it was also from a Setapp user, so that may be part of it, but I've tested with the Setapp version and everything works properly for me.

    To determine whether it has to do with the website or Marked itself, please open Terminal and paste the following command:

    open 'x-marked://addstyle?name=URL%20Test&css=body%7Bbackground%3A%23000%7D'

    Hit return and let me know what happens. If it works, you'll have a new style in your list called "URL Test", otherwise let me know what happens instead.

  4. 4 Posted by laurentstawski on 29 Apr, 2021 06:37 AM

    laurentstawski's Avatar

    The instruction via the terminal worked. A new style appears well.
    Laurent Stawski

    1 rue des Hayes - 41290 Conan
    06 03 76 92 12

  5. Support Staff 5 Posted by Brett on 29 Apr, 2021 11:47 AM

    Brett's Avatar

    Oh, well that's odd. That means that something is happening in the
    browser that's breaking the URL, which is going to be hard to track down
    if I can't replicate it. Are you running any content blocker plugins or
    anything that would alter urls? It would have to be something common to
    both Firefox and Safari...


  6. 6 Posted by laurentstawski on 29 Apr, 2021 12:46 PM

    laurentstawski's Avatar

    A priori I am not using anything special. I tried with a fourth browser after Edge (Vivaldi) and unfortunately the result does not change.
    Laurent Stawski

    1 rue des Hayes - 41290 Conan
    06 03 76 92 12

  7. Support Staff 7 Posted by Brett on 29 Apr, 2021 01:37 PM

    Brett's Avatar

    I will continue to look into this, but I don't have a solution for you
    at present. You'll need to manually install for the time being.


  8. 8 Posted by laurentstawski on 30 Apr, 2021 08:50 AM

    laurentstawski's Avatar

    Thank you again for your help. It seems to me that the difficulties arose with the switch to Mac M1

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac