Cannot enable syntax highlight

Victor Gutierrez's Avatar

Victor Gutierrez

20 Apr, 2021 06:58 PM

// Please enter a detailed description of the issue // Description of the issue:

Hey, I don't know when did this happened. I thought that I had syntax highlight enabled, but I recently noticed that I didn't. When trying to enable it, Marked doesn't let me tick that box. Regardless of the file Marked has opened. I am including a picture of when I mean. Is there a way to enable syntax highlight? why is my Marked app not letting me do it?

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Open file that includes code
  2. Select system preferences

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit) Marked 2 1021 (Direct)

macOS Version: 11.2.3

allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: YES
codeCanWrap: NO
collapsibleHeadlines: NO
convertGithubCheckboxes: YES
convertGithubEmoji: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 0
defaultProcessor: MultiMarkdown
enableMiniMap: NO
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: NO
includeKatex: NO
limitTextWidth: NO
mathNumberEquations: NO
mathNumberEquationsSide: 0
mathNumberEquationsAMSOnly: NO
minimalJavaScript: NO
permissionGranted: NO
printHeaderFirstPage: NO
printFooterFirstPage: NO
processHTMLFiles: YES
removeMetadataForPreview: YES
removeYAMLHeaders: YES
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: YES
shouldLoadCritic: NO
syntaxHighlight: NO
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: NO
useCustomPreprocessor: NO
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 20 Apr, 2021 07:32 PM

    Brett's Avatar

    In the top section of that preference pane there's an option titled
    "Style verbatim (code) blocks as poetry." Do you have that checked? If
    so, it will disable syntax highlighting.


  2. 2 Posted by gutierrez.victo... on 20 Apr, 2021 07:41 PM

    gutierrez.victor's Avatar

    Thank you. That solved the issue!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Screen_Shot_2021-04-20_at_12.54.11_PM.png 27.2 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac