Marked 2 hangs while loading images

Mandar's Avatar


25 Sep, 2020 02:03 PM

I'm on macOS Catalina 10.15.6 and using the cloud version of Marked 2.

Until recently Marked 2 was working just fine, asking for permissions when it needed to load images from new folders. Now, if I open a file with images, I get asked for permissions. On granting permissions nothing happens ... Marked 2 shows "Loading..." and beachballs forever, until I am forced to Force Quit it.

I have tried erasing and reinstalling Marked 2, but that hasn't solved the issue. The System Preferences, Security & Privacy panel doesn't list Marked 2 under the Files & Folders list.

Kindly advise.

  1. Support Staff 1 Posted by Brett on 25 Sep, 2020 02:51 PM

    Brett's Avatar

    I'll need to do some testing in this, it's possible something changed when I tried to fix some related crashes. Where are your images stored in relation to the Matkdown file you're opening?

    - Brett

  2. 2 Posted by Mandar on 25 Sep, 2020 03:47 PM

    Mandar's Avatar

    Two levels down in a subfolder. But I also tried copying to the same folder as the markdown and got the same results.

  3. Support Staff 3 Posted by Brett on 25 Sep, 2020 04:05 PM

    Brett's Avatar

    That's really odd. I think the easiest thing for right now would be to
    convert your license over to a direct (Paddle) one and see if that
    helps. Download the app from (Free Demo) and see
    if you still have the issue, and if not, I'll send you a free license
    for that version.


  4. 4 Posted by Mandar on 25 Sep, 2020 05:06 PM

    Mandar's Avatar

    Works perfectly fine with the free demo version downloaded from

  5. Support Staff 5 Posted by Brett on 25 Sep, 2020 05:18 PM

    Brett's Avatar

    Ok, sending a license to the email you registered with here. Let me know if you don't get it in the next 30 minutes.

  6. Brett closed this discussion on 25 Sep, 2020 05:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac