Crash on startup when modified kramdown

Jonathan Wheeler's Avatar

Jonathan Wheeler

30 Aug, 2020 09:15 PM


I've been trying to get kramdown set up as a custom processor. I was getting an error because the shebang in kramdown looks for #/usr/bin/env ruby_executable_hooks. I tried changing the shebang to #!/usr/bin/env ruby, but now Marked2 crashes on startup, and I can't change any fo the settings. I tried reverting the shebang, and reinstalling Marked, but no success.


  1. Support Staff 1 Posted by Brett on 01 Sep, 2020 01:36 PM

    Brett's Avatar

    The issue with using env is that a custom processor runs in its own
    environment, meaning the `env` that `env` is trying to get is not the
    one you get from a login shell. I would try changing your shebang to a
    full path (e.g. /usr/bin/ruby) or using rvm wrappers or similar to force
    load a specific ruby. It gets complicated if you're using an
    environment-based version manager.

    As far as the crash, I have to assume that the custom processor is
    causing it, and would hope that by editing the script you'd be able to
    get it to start, even if you need to pare down the script to simply
    taking input and `put`ting it out to STDOUT for debugging purposes. If
    that fails, you'll need to delete preferences to clear out the custom
    processor you have loaded. (and no, it _shouldn't_ crash on an error, it
    should display the STDERR results for you, so that's a bug on my end for


  2. 2 Posted by Jonathan Wheeer on 03 Sep, 2020 01:54 PM

    Jonathan Wheeer's Avatar

    I think my problem with the instacrashes was that I was trying to reopen the windows from last time. When I clicked "don't reopen" then I was able to make the adjustments in the preferences.

  3. Brett closed this discussion on 25 Sep, 2020 04:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac