Two $ in a paragraph not displayed correctly in Marked 2, HTML is good just display is incorrect.

Doug Knapman's Avatar

Doug Knapman

10 Aug, 2020 09:32 PM

// Please enter a detailed description of the issue // Description of the issue: A $ appears to mess with the display of text in Marked. The HTML is correct. I tried using \$

Here is text that was displayed in attached screenshot.

Test $5,000.00 what is happening second $3,700

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. A sequence with two $ does not display correctly in Marked 2

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit) Marked 2 990 (Setapp)

macOS Version: 10.15.6

allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: YES
convertGithubCheckboxes: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 0
defaultProcessor: MultiMarkdown
enableMiniMap: NO
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: YES
includeKatex: NO
limitTextWidth: NO
minimalJavaScript: NO
permissionGranted: NO
printHeaderFirstPage: NO
printFooterFirstPage: NO
processHTMLFiles: YES
removeMetadataForPreview: NO
removeYAMLHeaders: NO
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: YES
shouldLoadCritic: 1
syntaxHighlight: YES
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: NO
useCustomPreprocessor: NO
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 10 Aug, 2020 10:13 PM

    Brett's Avatar

    If you're not using math equation rendering, disable both MathJax and
    KaTeX in Preview preferences. Two dollar signs in a line denote a
    mathematical equation when those are enabled and your text is being
    interpreted as such.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Screen_Shot_2020-08-10_at_17.30.44.pdf 43.9 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac