Marked 2 crashes when I try to "Copy Rich Text"

Andreas Busch's Avatar

Andreas Busch

25 May, 2020 09:37 AM

// Please enter a detailed description of the issue // Description of the issue:

Marked 2 crashes when I try to "Copy Rich Text".

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Open text in Marked 2 (from MultiMarkdown Composer)
  2. Copy text in rich text format via menu
  3. Crash

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit) Marked 2 987 (Direct)

macOS Version: 10.14.6

allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: YES
convertGithubCheckboxes: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 103
defaultProcessor: MultiMarkdown
enableMiniMap: YES
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: NO
includeKatex: NO
limitTextWidth: NO
minimalJavaScript: NO
permissionGranted: YES
printHeaderBottomLeft: %date - %time
printHeaderBottomRight: Seite %page von %total
printHeaderFirstPage: NO
printFooterFirstPage: NO
printHeaderTopLeft: %title
processHTMLFiles: YES
removeMetadataForPreview: NO
removeYAMLHeaders: NO
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: YES
shouldLoadCritic: NO
syntaxHighlight: YES
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: YES
customMarkdownProcessor: /usr/local/bin/pandoc
useCustomPreprocessor: NO
customPreprocessor: ~/Documents/scripts/lazyfootnotes.rb
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 25 May, 2020 02:26 PM

    Brett's Avatar

    Does this happen with any document you try it with, or a particular


  2. 2 Posted by Busch, Andreas on 25 May, 2020 04:44 PM

    Busch, Andreas's Avatar


    thanks for the quick reaction!

    Tried it with three recent files, all led to a crash when I tried to "Copy Rich Text".

    Shall I send you the files? They are not in any way special - except they're in German (always worried umlauts might be a problem)...

    Best wishes,


  3. Support Staff 3 Posted by Brett on 25 May, 2020 04:56 PM

    Brett's Avatar

    Yes, please. I’m not seeing any issues on my end, so anything that would help me replicate the issue would be helpful.


  4. 4 Posted by Busch, Andreas on 25 May, 2020 06:32 PM

    Busch, Andreas's Avatar


    here are three files; all crashed when I had them loaded and clicked the "Copy Rich Text" menu (I did not select the text beforehand - should I?).

    On a side note, these are files for my lectures which I videotape - with the help of Marked's Teleprompter mode. Since you wrote (on Twitter?) that I was the only other person apart from you who seemed to use that mode, it seems just fair that you can have a look at them. It's political science, and they are on political parties (in case your German is a bit rusty...).

    Thanks for your help! Hope you can squash that bug.

    Best wishes,


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac