Marked 2 crashes as soon as I try to open a file

David Passarelli's Avatar

David Passarelli

24 Mar, 2020 03:41 PM

// Please enter a detailed description of the issue // Description of the issue: Marked 2 crashes as soon as I try to open a Markdown file.

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Launch Marked 2
  2. cmd-o to browse for a file
  3. double-click on a valid MD file
  4. app disappears from the screen (without displaying the document at all)

// If applicable please attach a sample document that causes the issue for you. (see attached)

// Configuration (do not edit) Marked 2 985 (Mac App Store)

macOS Version: 10.15.3

additionalMathJaxConfig:
allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: NO
convertGithubCheckboxes: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 3
defaultProcessor: Discount (GFM)
enableMiniMap: NO
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: YES
includeKatex: NO
limitTextWidth: NO
minimalJavaScript: NO
outlineModeExtensions:
permissionGranted: NO
printHeaderBottomLeft:
printHeaderBottomRight:
printHeaderFirstPage: NO
printFooterFirstPage: NO
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: NO
removeMetadataForPreview: NO
removeYAMLHeaders: NO
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: NO
shouldLoadCritic: NO
syntaxHighlight: YES
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: NO
customMarkdownProcessor:
useCustomPreprocessor: NO
customPreprocessor:
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 24 Mar, 2020 06:33 PM

    Brett's Avatar

    Hi David,

    Could you open Utilities/Console.app and see if there's a crash report
    available for Marked?

    -Brett

  2. 2 Posted by David Passarell... on 24 Mar, 2020 06:43 PM

    David Passarelli's Avatar

    Hi Brett,

    I did check the Console before submitting the report, there doesn’t seem to be any entries for Marked. Otherwise I would have attached. Please let me know if there’s anything I need to turn “on” to try and get one.

    Thanks!

    ________________________________

  3. Support Staff 3 Posted by Brett on 24 Mar, 2020 07:10 PM

    Brett's Avatar

    So just to clarify, Marked is fully crashing, meaning it disappears from the Dock (or loses its indicator if it's there permanently), correct?

    If that's the case, I'm not sure why a crash report wouldn't show up. You may be able to get some diagnostics by opening Preferences->Advanced, turning on Debug Mode at the bottom, and setting the popup button to "All". That would then direct logging messages to its own log, accessible by using Help->Open Debug Log. However, this logging starts as the document is being processed for display, so if something is crashing it before reaching that point, nothing will show up in that log.

    Further questions:

    1. Have you tried with multiple files and had the same result with all of them?
    2. Are the files located somewhere other than the local disk, such as a network drive or removable media?
    3. After the crash, does macOS ever notify you that "Marked 2 quit unexpectedly?"
  4. 4 Posted by David Passarell... on 24 Mar, 2020 10:14 PM

    David Passarelli's Avatar

    Yes, Marked is fully crashing, disappearing from the Dock altogether.

    I tried turning on Debug mode, and something interesting happens...when I close the Preferences window, Marked crashes again, and disappears from the Dock.

    Same thing happens if I open the "About" window...when I close it, Marked disappears.

    I do not see any messages about "Marked 2 quit unexpectedly..." I have seen that before for other apps, but not for this one.

    Yes, the files are all located on the local HDD. This seems to be related to a problem with windowing more than files...? Perhaps the crash happens when the Open dialog is closed, not when the file is being read.

  5. 5 Posted by David Passarell... on 24 Mar, 2020 10:19 PM

    David Passarelli's Avatar

    Just some more info...

    I have been using Marked 2 for several years, so this is a very new problem for me. I just upgraded from Mojave to Catalina within the past week, and I would guess (to the best of my memory) that this problem started happening after that. So we could blame it all on Apple. Perhaps a Qt incompatibility? (not sure if you are using that, but trying to make a semi-intelligent guess)

  6. Support Staff 6 Posted by Brett on 24 Mar, 2020 10:33 PM

    Brett's Avatar

    I’ve never seen an issue that resembles this one. I’d have to recommend deleting all preference files and restarting your computer to see it clearing out preferences and cache makes a difference. If you need instructions for finding the preference files, let me know.

    - Brett

  7. 7 Posted by David Passarell... on 24 Mar, 2020 10:51 PM

    David Passarelli's Avatar

    Okay, I’ll give that a try and let you know what happens. Thanks again for your support!

    ________________________________

  8. 8 Posted by David Passarell... on 03 Apr, 2020 08:52 PM

    David Passarelli's Avatar

    Okay, I think I may have finally found the source of this behavior...

    It seems to happen when the option "Quit after closing last window" is checked. If I uncheck that option, and click "Refresh", then the app works as before. I can select a document to open, and the app doesn't disappear unexpectedly.

    Some how, the code must think that closing the "Open" dialog is like closing the last open document window, and then decides to quit. That could explain why there is no crash report.

    At least I got it working again!

  9. Support Staff 9 Posted by Brett on 03 Apr, 2020 09:11 PM

    Brett's Avatar

    Oh wow. Not sure when that started happening, but I'll look into it. Thanks for letting me know.

    - Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • PunchOutSetupRequest.md 24 Bytes

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac