CriticMarkup Comments Not Showing Without Highlight Element + Syntax Highlighting Greyed Out

emily's Avatar


26 Dec, 2019 08:21 PM


I have two issues, and hope it's okay to include both in this post. If I need to divide, please let me know. Also, forgive me if I've missed the answers to these somewhere—I read through the documentation and did try searching in the forum first as well.

CriticMarkup Comments

I'm fnding that CriticMarkup comments won't show unless I've included highlighted text prior to them.

On the CriticMarkup site, it lists the 5 types, and has comments independent of highlights:

  • Addition {++ ++}
  • Deletion {-- --}
  • Substitution {~~ ~> ~~}
  • Comment {>> <<}
  • Highlight {== ==}{>> <<}

However, when I have a comment, it doesn't show anywhere in Marked2. For the highlighted text with comment, it comes up from the bottom, and I have tried hovering over the place where I know the comment to be, but I can't seem to find a way it have it show up.

This may just not be a feature in Marked2, but I didn't see anything stating that that CriticMarkup type isn't supported. Is there any way to have the note display in-body like additions do?

Syntax Highlighting Greyed Out

The option for syntax highlighting is greyed out in my settings. I read the section in the manual and didn't see anything about needing to install anything additional.

Also, and please forgive my technical ignorance, but is there syntax highlighting for HTML? I saw the section about including HTML files after processing, but when I tried putting HTML within code markers, it still renders live in Marked. I was hoping to have live syntax highlighting for it once I can get the highlighting turned on, but wasn't sure if that is possible.

Thank you!

  1. Support Staff 1 Posted by Brett on 26 Dec, 2019 09:07 PM

    Brett's Avatar

    Hey Emily,

    For the comments, check in the gear menu at the lower right of the
    preview to ensure that Proofing->Show Comments is enabled. This can be
    toggled with ⌘\, so it might have been toggled accidentally. Let me
    know if that solves that issue for you.

    As for the syntax highlighting, the only thing that should be able to
    disable that checkbox is if "Style verbatim blocks as poetry" is enabled
    in the Layout and Typography section of the Style preferences. If that's
    checked, uncheck it and everything should work as desired. If there's
    something else going on, let me know.

    Yes, HTML code should be recognized by the highlighter, and if it's
    included within code fences or using a code include syntax, it should
    show the actual XML code. If you're not getting that to work, please
    attach a sample document (or a zip with multiple if it's an
    included-file situation) and I'll see what's up.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Comment-with-highlight.jpg 3.25 MB
  • independent-note.jpg 3.99 MB
  • can-comment-show-in-body.jpg 3.73 MB
  • syntax-highlighting-greyed.jpg 172 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac