Checkbox formatting problems with Bear

Matthew L.'s Avatar

Matthew L.

11 Dec, 2019 10:32 PM


Since I have gone all-in with Bear I decided to make the $14 purchase of Marked2 so that I could easily preview my markdown documents. However, right away, I am seeing formatting problems with checkboxes. It did take me a little bit of setup, such a selecting Discount (GFM) as my markdown format, but after getting formatting as close to correct as I can get it, I am seeing a problem with the rendering of the checkbox markdown token where after the first occurrence of an H3 the checkboxes look good, but after the second H3 and beyond checkboxes are rendered as " -[ ]". Please see the screen shots of both Bear and Marked 2 which views the same text and how the green circled text is formatted correctly but the red circled text has the problem.

Is there some means to fix this problem? It pretty much ruins the preview for me.


  1. Support Staff 1 Posted by Brett on 11 Dec, 2019 10:53 PM

    Brett's Avatar

    Wild stab because I’m not at a machine to test right now, but it looks like you need a blank line before the second list. Standard markdown formatting.

    - Brett

  2. 2 Posted by Matthew L. on 11 Dec, 2019 11:30 PM

    Matthew L.'s Avatar

    While Marked2 does put significant spacing both before and after an H3 when it renders, if you look at the Bear markdown text there is no blank line after the first H3 and those GitHub checkboxes render just fine. I tried adding some blank lines both after the second H3 and before the checkboxes to see if there was any change but Marked2 actually ignores them completely.

  3. Support Staff 3 Posted by Brett on 11 Dec, 2019 11:51 PM

    Brett's Avatar

    Please export your example note as markdown and attach.

    - Brett

  4. 4 Posted by Matthew L. on 12 Dec, 2019 02:00 AM

    Matthew L.'s Avatar

    Thanks for your offer to help, but I actually figured out the problem. I had imported the markdown text from Boostnote which puts a space before each "- [ ]" and since Bear doesn't care about spaces I didn't see them there. I didn't consider that they would poison the syntax interpreter in Marked2. Once I started removing them, things started to look closer to the intended design but it would seem that spaces are sometimes translated as an indents in Marked2 where they are always just spaces in Bear which seems to treat whitespace (except tabs) as just "filler". This is kind of ironic since a blank line in Bear is completely ignored in Marked2 so if I need blank lines I will need to figure out another way, assuming that is how they'd render in a PDF or HTML.

    This is obviously not Marked2's fault, but of course the Find/Replace in Bear does not match the pattern " - [ ]" as it appears that once they are rendered into a checkbox in the Bear UI, they are no longer treated as their markdown equivalent when using search. This, of course, is goofy. I can just export it as text and use a "proper" text editor clean it up, but gee-whiz, right?

    Thanks again.

  5. Matthew L. closed this discussion on 12 Dec, 2019 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac