Pre-formatted text blocks rendering as italic

jms1's Avatar

jms1

04 Nov, 2019 09:35 PM

I'm using the "Github" stylesheet that comes with Marked. After upgrading to 2.5.35(978), documents containing blocks of code within the triple-backtick construct are being rendered as italic rather than monospaced.

The same issue is also affecting a custom stylesheet that I created by copying and modifying the Github stylesheet.

Did something change, is this expected? If so, I'll have to figure out where in the stylesheet I need to override that. I use these triple-backtick constructs heavily, in many cases to show "screenshots", many of which require that columns "line up" from one line to the next, and this requires mono-spaced text.

  1. Support Staff 1 Posted by Brett on 04 Nov, 2019 10:09 PM

    Brett's Avatar

    Try Preferences->Style->Style verbatim (code) blocks as poetry. It
    should be unchecked.

    -Brett

  2. 2 Posted by jms1 on 04 Nov, 2019 11:08 PM

    jms1's Avatar

    That fixed it, thanks.

    I don't recall ever seeing that preference before, let alone turning it on. Is this a new option in a recent version of Marked? If so, I think it might make sense for this option's default to be "off", especially when upgrading from a previous version.

    Thanks again.

  3. Support Staff 3 Posted by Brett on 05 Nov, 2019 12:40 AM

    Brett's Avatar

    It’s been there for years, and has always defaulted to off.

    Thanks,
    Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac