Activate license without network connectivity

jms1's Avatar

jms1

09 Oct, 2019 04:46 PM

I'm using Marked2 on an "air-gapped" machine which, for security reasons, is not allowed to be connected to any kind of network. (This machine is our internal CA.)

Is there a way to do the activation manually? Having to remove and re-install the software after the seven-day demo timer expires is getting to be kind of irritating.

  1. 1 Posted by jms1 on 09 Oct, 2019 05:15 PM

    jms1's Avatar

    Also, not sure if this is related or not, but my normal laptop (running macOS 10.13.6) just upgraded Marked2 to v2.5.35(978), and it's suddenly prompting me for the license code again. When I enter it, the app crashes. If I click on "Continue trial" it seems to work okay, but I don't want to have it become totally unavailable next week.

  2. Support Staff 2 Posted by Brett on 09 Oct, 2019 05:58 PM

    Brett's Avatar

    Ok, so the biggest change in 2.5.35 was an update to the Paddle
    licensing libraries. I was behind on getting them up to date, and the
    symptoms you're describing (re-register, crash) are what were happening
    to any users on 10.15. The update seems to have solved it for 10.15, but
    I haven't tested on 10.13 recently. I will have to see if I can
    replicate.

    As a consequence of the update, users on pre-Catalina systems are faced
    with having to re-register, so it's not unexpected (to me) that you're
    seeing the prompt. Annoying for sure, though.

    As far as the original question about activating without network,
    there's no simple way. However, if you register the app on a networked
    machine, you should then be able to copy the entire
    "~/Library/Application Support/Marked 2/" folder to the same location on
    the air-gapped machine and then launch Marked. It should, I think,
    accept itself as registered. Caveat, the latest version does a license
    validation on startup that does require network, so if the registration
    doesn't stick for you, please let me know.

    In the meantime, I'm first concerned about the crash and will get back
    to you after some testing.

    -Brett

    The crash you're getting

  3. 3 Posted by jms1 on 09 Oct, 2019 08:26 PM

    jms1's Avatar

    So the Paddle library is now going to want to connect to Paddle's servers every time the program starts?

    Why is that? Do they have some kind of "license revocation" functionality which didn't exist before? Are they harvesting information from/about your users?

    The other thing I noticed is that, where it used to connect to api.paddle.com before, now it's connecting to data.paddle.com (love me some Little Snitch) which makes me suspect some kind of data-harvesting or analytics or something like that. Does Paddle have a web page which explains exactly what they're doing?

  4. Support Staff 4 Posted by Brett on 09 Oct, 2019 09:10 PM

    Brett's Avatar

    As far as I know, that's the way it's always been, one quick ping to
    verify the validity of the current activation at launch. I could be
    mistaken, though, and I'll look further into the current implementation
    to see what I can avoid there. The only data Paddle collects is
    anonymized usage stats (for my use), which is opt-in.

  5. 5 Posted by jms1 on 09 Oct, 2019 11:22 PM

    jms1's Avatar

    Where/how do I opt in or opt out of this? I don't see anything in the preference dialogs for it. (I've always implemented my own "opt out" preference by configuring Little Snitch to not allow Marked to make any outbound connections, once the license itself has been accepted.)

  6. Support Staff 6 Posted by Brett on 10 Oct, 2019 12:05 AM

    Brett's Avatar

    It would ask you on 2nd run if you wanted to opt in. If you've never
    received that dialog, you're not opted in.

    -Brett

  7. Support Staff 7 Posted by Brett on 10 Oct, 2019 12:09 PM

    Brett's Avatar

    Ok, so back to the crashing issue. I ran a test on 10.13, tell me if this looks right for simulating your circumstances:

    • Downloaded and installed v2.5.33
    • Registered using existing key
    • Quit and relaunched, registration sticks
    • Use the in-app updater to get v2.5.35

    For me the registration stuck after the update, and I was unable to get to a point where it would crash. The license format has changed from .34 to .35, pretty drastically, but I can verify that the older license should smoothly transition.

    So 2 questions: have you tried with LittleSnitch off to see if it makes a difference? And can you find a crash report for me in Console.app?

  8. 8 Posted by jms1 on 11 Oct, 2019 01:20 PM

    jms1's Avatar

    So it turns out I had added a Little Snitch rule blocking all outbound traffic to "paddleapi.com", for ALL programs. Apparently the work laptop has a few other programs using Paddle, and one of those programs was trying to "phone home" every few minutes. When I disabled that rule, Marked2 was able to register, and now it tells me that I'm awesome again...

    Next up, now that it's registered on my normal laptop, copying that Application Support directory over to the CA machine (after letting the security guy scan the USB stick first, grumble grumble)...

  9. Support Staff 9 Posted by Brett on 11 Oct, 2019 02:15 PM

    Brett's Avatar

    Please let me know how that goes. I'm a bit concerned that it won't run
    if it can't validate when it wants to, though I tested here with network
    disabled and it _seems_ ok.

    -Brett

  10. 10 Posted by jms1 on 11 Oct, 2019 09:07 PM

    jms1's Avatar

    I copied the latest DMG along with the Application Support folder over to the air-gapped machine, using a USB stick. I renamed the old ~/Library/Application Support/Marked 2 folder and copied in the one from the USB stick, and when I ran Marked2, it considers itself to be registered.

    Thanks for your help.

  11. Support Staff 11 Posted by Brett on 11 Oct, 2019 09:15 PM

    Brett's Avatar

    Excellent, glad this is all working out!

    -Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac