Highland 2 file rendering issue

Watts Martin's Avatar

Watts Martin

02 Aug, 2019 02:51 PM

// Please enter a detailed description of the issue // Description of the issue:

Highland files (.highland) do not render with proper formatting.

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Drop a .highland file on Marked
  2. Observe the lack of Fountain formatting

// If applicable please attach a sample document that causes the issue for you.

I can create one for you if you need it, but it seems pretty consistent. The Highland file that I was trying this with is a screenplay, with a Fountain file inside the Highland textbundle.

// Configuration (do not edit) Marked 2 974 (Direct)

macOS Version: 10.14.6

additionalMathJaxConfig:
allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: NO
convertGithubCheckboxes: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 3
defaultProcessor: Discount (GFM)
enableMiniMap: YES
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: NO
includeKatex: NO
limitTextWidth: NO
minimalJavaScript: NO
outlineModeExtensions:
permissionGranted: YES
printHeaderBottomLeft:
printHeaderBottomRight:
printHeaderFirstPage: NO
printFooterFirstPage: NO
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: NO
removeMetadataForPreview: NO
removeYAMLHeaders: YES
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: NO
shouldLoadCritic: NO
syntaxHighlight: YES
syntaxHighlightOnlyLang: NO
useCustomMarkdownProcessor: NO
customMarkdownProcessor: /opt/brew/bin/asciidoctor -o -
useCustomPreprocessor: NO
customPreprocessor:
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 02 Aug, 2019 03:37 PM

    Brett's Avatar

    I will do some testing on this, but in the meantime, be aware that you can manually enable fountain processing using the gear menu in the lower right of the preview window.

    Thanks!

    Brett

  2. 2 Posted by Watts Martin on 02 Aug, 2019 03:41 PM

    Watts Martin's Avatar

    "Process as Fountain" shows up as checked in the gear menu -- it's just not actually processing it as Fountain. :)

    This doesn't happen with actual .fountain files, which show up just fine.

  3. Support Staff 3 Posted by Brett on 02 Aug, 2019 04:19 PM

    Brett's Avatar

    Any chance you could send me the file in question for testing? You can
    make this conversation private if you want to avoid indexing and other
    eyes on it.

    -Brett

  4. 4 Posted by Watts Martin on 03 Aug, 2019 12:40 AM

    Watts Martin's Avatar

    I can attach a test document here which exhibits the same issue.

  5. Support Staff 5 Posted by Brett on 09 Aug, 2019 04:57 PM

    Brett's Avatar

    Ok, so this is weird. Using the latest Highland buikld (2.0.0GM Scooby (4257)), your test file does exactly what you say. But if I copy the text directly from your test file into a new document, that .highland document behaves as expected in Marked. I don't know Highland very well (at all), so is there some setting on a document that would be tricking Marked into rendering it oddly?

    Even when it doesn't "render", it's still in Fountain mode. The font and spacing are there, and it even recognizes some of the syntax. But it appears to be rendering the document as Markdown only, not as Fountain with MD mixed in. Which I didn't realize was an option now, but like I said, it does work if I just copy your text into a new file.

    Any insight you can offer on your particular Highland settings that might affect the way the file is saved?

  6. 6 Posted by Watts Martin on 13 Aug, 2019 02:54 PM

    Watts Martin's Avatar

    Probably not, unfortunately -- Highland doesn't actually have very many
    settings to fiddle with, and none of them look like they should affect
    file saving. While the document I've actually been working on was one
    that I was sharing with Slugline, an iOS scriptwriting app that can read
    .highland files, the one I sent you was a new one created from scratch
    that shouldn't have had anything weird about it.

    The build you mention below isn't the latest build, though; Highland is
    at version 2.6. (The most up-to-date version is 2.6.2 build 6286.) I
    can't think what would have changed that would have affected this, since
    I presume Marked is just rendering the .fountain file inside the
    .highland TextBundle and not trying to read anything else in it?

    -- Watts

  7. Support Staff 7 Posted by Brett on 13 Aug, 2019 02:59 PM

    Brett's Avatar

    Your assumption is correct, although it does check to see if it's
    viewing markdown or fountain. Like I said, it appears to be partially
    rendering it. I will have to test with the newer version. My beta copy
    had just auto-updated, assumed it was the most recent.

    -Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac