U+00A0 no-break space added around italic and bold

Sam's Avatar

Sam

26 Jul, 2019 10:12 AM

Hi,

When copy-pasting text from Marked 2 into an editor or a word processor, a no-break space (U+00A0) is added before and after the string in italics or bold. I've tested it with MS Word, Writer LO and a text editor, it happens with all three applications.

Of course the problem can be resolved, in the application, by searching and replacing those no-break spaces with a normal space, but maybe there's a simple way to have Marked 2 not introduce them in the first place?

Thanks
Sam

  1. Support Staff 1 Posted by Brett on 26 Jul, 2019 10:16 AM

    Brett's Avatar

    I assume this is happening with "Copy Rich Text?"

    -Brett

  2. 2 Posted by Samuel Arnet on 26 Jul, 2019 11:08 AM

    Samuel Arnet's Avatar

    No, the no-break spaces are only added when I select text in Marked 2
    and then "Copy" and paste it into the word processor (MS Word) by
    choosing either "Keep Source Formatting" or "Match Destination
    Formatting". They are *not* added when I choose "Keep Text Only" (but in
    this case the formatting is gone too, obviously).

    Neither are the no-break spaces added when I select text in Marked 2 and
    then "Copy Rich Text" and paste it into the word processor (MS Word) by
    choosing any of the three options mentioned above. Strangely, though,
    the text of the whole file is copied, not just the selected text, so
    "Copy Rich Text" is not an option in most circumstances.

  3. Support Staff 3 Posted by Brett on 26 Jul, 2019 11:14 AM

    Brett's Avatar

    When you do that you're essentially just copying text out of a web browser. The way that Rich Text editors interpret that can vary, but it's nothing that Marked is adding.

    - Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • ___1editor.png 31 KB
  • ___2marked2.png 40.4 KB
  • ___3processor.png 214 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac