First 'File-Open' doesn't work.

Paul Jacobs's Avatar

Paul Jacobs

02 May, 2019 07:21 AM

// Please enter a detailed description of the issue // Description of the issue: Unable to open file using keyboard operations (See below)

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Open marked2 (not already open)
  2. Type Cmd-o
  3. Navigate to file using tab & up/down arrows (not mouse)
  4. Press return when file selected ('Open button is blue, indicating default, but not in focus)
  5. Marked2 closes--nothing happens.

Close Marked2 (Cmd-q). Repeat, but in step 4, highlight the 'open' button (by tabbing to it), then press either space bar or return. Same--nothing happens.
Close Marked2. Repeat using mouse. Same.
If a file is opened any other way (drag/drop, reopen previous file), then the above instructions DO work for subsequent file open operations. Only the first doesn't.

Previously, I always drag/dropped file from TextMate 2. I started using Emacs (terminal) in an attempt to reduce my mouse mileage, so started opening files in Marked2 from the keyboard.

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit) Marked 2 974 (Mac App Store)

macOS Version: 10.14.4

allowPageBreakInCode: NO
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: YES
convertGithubCheckboxes: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 2
defaultProcessor: MultiMarkdown
enableMiniMap: NO
excludeBlockQuotesFromCounts: YES
excludeFootnotesFromCounts: YES
excludeVerbatimFromCounts: YES
excludeCaptionsFromCounts: YES
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: NO
includeKatex: NO
limitTextWidth: NO
minimalJavaScript: YES
permissionGranted: NO
printHeaderFirstPage: NO
printFooterFirstPage: NO
processHTMLFiles: YES
removeMetadataForPreview: NO
removeYAMLHeaders: NO
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: YES
shouldLoadCritic: NO
syntaxHighlight: YES
syntaxHighlightOnlyLang: YES
useCustomMarkdownProcessor: NO
useCustomPreprocessor: NO
useFirstH1AsPrintTitle: YES

  1. Support Staff 1 Posted by Brett on 05 May, 2019 03:20 PM

    Brett's Avatar

    I'm not seeing this happen on my machine. After a fresh launch I'm able
    to use cmd-o, navigate to the file, then hit return to open without
    issue. Based on your thorough description I assume this is completely
    replicable for you. I'll see if I can dig up a reason this might be
    happening, but it's always harder when I can't confirm it locally. I'll
    do what I can.


  2. 2 Posted by Paul Jacobs on 14 May, 2019 08:00 AM

    Paul Jacobs's Avatar

    I think this issue is something to do with the general setting ‘Quit after closing last window’.
    When ON, opening Marked2 and selecting a file, click open/press return, Marked2 doesn’t open.
    'Reopen last file’ works, and so does subsequent opens.
    When OFF (unselected), Marked2 Cmd-O etc works as expected.

  3. Support Staff 3 Posted by Brett on 14 May, 2019 03:22 PM

    Brett's Avatar

    Nope, still works fine for me with that option on...

  4. 4 Posted by Paul Jacobs on 16 May, 2019 07:57 AM

    Paul Jacobs's Avatar

    Stumped. I tested on two back-to-factory, default installs of 10.14.5 and 10.13.6. Both the same. Can’t open a file with ‘Quit after closing last window’=ON. Guess I’ll turn it OFF ;)

  5. Support Staff 5 Posted by Brett on 16 May, 2019 01:02 PM

    Brett's Avatar

    But in both cases turning it off fixes the issue? That's weird, and
    weird that I can't replicate...


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac