Table of contents links stop working after exporting to pdf

Tonu's Avatar

Tonu

11 Mar, 2019 04:15 PM

Hi,
I am using Marked v. 2.5.31 (971) on OSX 10.11.6 (15G22010)
Table of contents works inside marked application but links become wrong after exporting to pdf.
When I checked it with adobe acrobat by clicking to content it redirects to default web browser
and tries to open file:///Users/myUserName/some_folder/doc/#generated_id_tag
It looks that generated links contain the full path to original *.md file but missing the file name.

How to overcome issue? Is there some option in setting to change?

Regards,
Tonu

  1. Support Staff 1 Posted by Brett on 11 Mar, 2019 05:01 PM

    Brett's Avatar

    This is a known issue with WebKit, which Marked uses to generate the
    preview and print the PDF. Internal (intra-document) links in PDF
    exports do not function. Until Marked gets the entire PDF engine
    rewritten, which could be a while, there is no solution for this issue.
    Sorry.

    - Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac