Dollar symbols in code-styled text confuse rendering

William Moss's Avatar

William Moss

28 Feb, 2019 07:33 PM

// Please enter a detailed description of the issue // Description of the issue:

Attempting to enter hexadecimal numbers in a code style, such as $00 through $FF, causes interpretation of the code as if the code were surrounded by the math style. Additionally, because it is in the backticks, it apparently escapes the math style so the span tags are actally visible.

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Create a .md file in a text editor such as BBEdit.
  2. Include a range with dollar symbols in code styling such as $00 up through $FF.
  3. Open the file in Marked.

// If applicable please attach a sample document that causes the issue for you.

DollarsInBackticks.md is my attached file that shows the ideal case, and several workarounds.

When opened in Marked (especially when using a theme like Upright Citizen), the odd behavior should be evident. As a bonus, the end includes other interesting behaviour of Marked and dollar signs I noticed, but are ancillary to my problem. :-)

// Configuration (do not edit) Marked 2 970 (Mac App Store)

macOS Version: 10.14.3

additionalMathJaxConfig:
allowPageBreakInCode: YES
bookTxtIsLeanpub: NO
summaryMdIsGitBook: NO
codeIsPoetry: NO
codeCanWrap: YES
collapsibleHeadlines: NO
convertGithubCheckboxes: YES
convertYAMLToMMD: NO
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: GitHub
defaultProcessor: Discount (GFM)
enableMiniMap: NO
excludeBlockQuotesFromCounts: NO
excludeFootnotesFromCounts: NO
excludeVerbatimFromCounts: NO
excludeCaptionsFromCounts: NO
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: YES
h1IsPageBreak: NO
h2IsPageBreak: NO
hrIsPageBreak: NO
includeMathJax: YES
limitTextWidth: NO
minimalJavaScript: NO
outlineModeExtensions:
permissionGranted: NO
printHeaderBottomLeft:
printHeaderBottomRight:
printHeaderFirstPage: NO
printFooterFirstPage: NO
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: YES
removeMetadataForPreview: NO
removeYAMLHeaders: NO
scrollToEdit: YES
shouldDetectCritic: YES
shouldHighlightMarkupErrors: NO
shouldLoadCritic: NO
syntaxHighlight: YES
syntaxHighlightOnlyLang: NO

  1. Support Staff 1 Posted by Brett on 28 Feb, 2019 07:45 PM

    Brett's Avatar

    This is always going to be an issue when MathJax is enabled. Are you
    using MathJax in your document? If not, disable it under
    Preferences->Style and the issue will go away.

    -Brett

  2. 2 Posted by W M on 28 Feb, 2019 07:55 PM

    W M's Avatar

    Thanks Brett. Your quick response fixed my issue.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • DollarsInBackticks.md 5.14 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac