Marked 2 work with a .md file for preview, but doesn't cant start with Scrivener file when I preview citations from a .bib?

Simon's Avatar

Simon

27 Feb, 2019 06:37 AM

Hello!

I use Scrivener as my writing program. I write in Markdown and using Marked 2 for a live preview. I really love how these two programs work together. Then I starting using Pandoc as a custom word processor in Marked 2 for generating my citations from a .bib file. But now when I drag the Scrivener icon to the Marked 2 icon a Marked 2 window appears but doesn't get past the ”loading” wheel and nothing happens. I tried the same thing with the .md file and then it works fine. So now I have to compile the Scrivener document and replace .md file for using Marked 2 to see updates appears in the preview.
I wonder if it's possible to solve this problem so Marked 2 can read the Scrivener file instead of the .md file. If so I don't have to compile the Scrivener file every time what to see the preview in Marked 2?

I used this guide on youtube https://www.youtube.com/watch?v=BrZRIU8IHaI&t=405s
and
this is what I have written under the advanced tab in Marked 2:

Path: /usr/local/bin/pandoc
Args: -f markdown -t html5 --bibliography=/Users/USR/Desktop/References.bib -s

I use the 2.5.30 (969) version of Marked 2.

Thanks.

  1. Support Staff 1 Posted by Brett on 27 Feb, 2019 04:59 PM

    Brett's Avatar

    Just to clarify, does dragging the same Scrivener document to Marked
    work when the custom processor is disabled?

    -Brett

  2. 2 Posted by Simon on 28 Feb, 2019 09:00 AM

    Simon's Avatar

    I disabled the custom processor and it works. When I enable the custom processor again everything works fine with .bib file.

    Thank you!

    - Simon

  3. Support Staff 3 Posted by Brett on 28 Feb, 2019 01:14 PM

    Brett's Avatar

    Glad to hear it's working for you! Not sure what would have been going
    wrong there.

    Thanks,
    Brett

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac