Not working on network share files.

Alexandre Dumas's Avatar

Alexandre Dumas

19 Nov, 2018 10:34 AM

All documents i need to work on are based on the shared folder in a local server which is always mounted.
The folders are shared through the AFP protocol. Any app can without problem open the file from the finder.
But Marked don't, it show the spinner and Loading… message.
I haven't see any way to authorize a shared folder as I suspected that it could be a sandboxing problem. But I run the website Marked version (non mac appstore). The same file open just fine from the computer or even a usb key, it doesn't work only from the network shared folder.
This beahaviour doesn't feel right. Any app, even big ones, could open files from the shared folder, but here it doesn't open just a simple text files. At least, it should inform the user about it's incapacity ?
Am I missing something or is Marked incapable of opening file from network shared folders ?

Best regards

  1. Support Staff 1 Posted by Brett on 19 Nov, 2018 10:44 AM

    Brett's Avatar

    Are you certain the share is mounted through AFP? I'm able to open files
    from an AFP share without any issue...

    -Brett

  2. 2 Posted by Alexandre Dumas on 19 Nov, 2018 01:03 PM

    Alexandre Dumas's Avatar

    Hi Brett,
    yes i am sure it's AFP. The serveur adress is afp://company._afpovertcp._tcp.local/SharedFolders/

    I Think I found the bug.
    The file use a YAML front matter. And it works telling Marked to treat as MMD meta but not if I ask ignore which was by default. The strange thing is that it works without fixing this pref on a local drive but fail from a shared folder on the network.
    Best regards.

  3. Support Staff 3 Posted by Brett on 19 Nov, 2018 05:18 PM

    Brett's Avatar

    Can I see a test document that exhibits the issue?

    -Brett

  4. 4 Posted by Alexandre Dumas on 19 Nov, 2018 05:30 PM

    Alexandre Dumas's Avatar

    Here is the file.
    just the start of the file and without completed data. Hope you can reproduce and fix taht.
    Luckily, I just have to not let the option of ignoring YAML Frontmatter for having no issue.

  5. Support Staff 5 Posted by Brett on 19 Nov, 2018 05:46 PM

    Brett's Avatar

    Oddly, I'm unable to reproduce the issue. I'll keep an eye on it, but
    glad to hear you have a workaround for now.

    Thanks,
    Brett

  6. 6 Posted by Alexandre Dumas on 20 Nov, 2018 10:57 AM

    Alexandre Dumas's Avatar

    Brett,

    I shorten the file too much. The one I send you works, this one more long doesn't work. As the front matter option make it work, I didn't suspect that the problem would be down in the file.
    So with this file, i got the problem. It doesn't display but neither from desktop or shared folder when set on ignore. I can't reproduce the version where it only works locally but not from shared folders.
    Strange.

  7. 7 Posted by Alexandre Dumas on 20 Nov, 2018 11:11 AM

    Alexandre Dumas's Avatar

    With the file, it's better.

  8. Support Staff 8 Posted by Brett on 20 Nov, 2018 01:30 PM

    Brett's Avatar

    It seems to be caused by the empty "keywords" key in the YAML. I'm not
    quite sure why, really, but if I remove that line it seems to function
    fine.

    -Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac