Table of Content issue

Yaroslav's Avatar

Yaroslav

27 Oct, 2018 05:45 PM

// Please enter a detailed description of the issue // Description of the issue:

Disabled export setting:
- Add page breaks before: h1, h2, Footnotes

Enabled export settings:
- Print table of contents (all markers set to "1.") - Page break after TOC

The exporting appears to the follow PDF (the document have been cut to the first two pages by my own, this is not an issue). But the empty first page (there's should be both H1 as in Swiss template) and glitches with TOC and both H1 content.

Meanwhile if either delete second H1 tag or disable Replace horizontal rules with page breaks and enable Add page breaks before h2 it exports document correct.

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit) Marked 2 962 (Mac App Store)

macOS Version: 10.14

additionalMathJaxConfig:
allowPageBreakInCode: TRUE
bookTxtIsLeanpub: TRUE
summaryMdIsGitBook: TRUE
codeIsPoetry: TRUE
codeCanWrap: TRUE
collapsibleHeadlines: TRUE
convertGithubCheckboxes: TRUE
convertYAMLToMMD: TRUE
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 101
defaultProcessor: MultiMarkdown
enableMiniMap: TRUE
excludeBlockQuotesFromCounts: TRUE
excludeFootnotesFromCounts: TRUE
excludeVerbatimFromCounts: TRUE
excludeCaptionsFromCounts: TRUE
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: TRUE
h1IsPageBreak: TRUE
h2IsPageBreak: TRUE
hrIsPageBreak: TRUE
includeMathJax: TRUE
limitTextWidth: TRUE
minimalJavaScript: TRUE
outlineModeExtensions:
permissionGranted: TRUE
printHeaderBottomLeft:
printHeaderBottomRight: %page
printHeaderFirstPage: TRUE
printFooterFirstPage: TRUE
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: TRUE
removeMetadataForPreview: TRUE
removeYAMLHeaders: TRUE
scrollToEdit: TRUE
shouldDetectCritic: TRUE
shouldHighlightMarkupErrors: TRUE
shouldLoadCritic: TRUE
syntaxHighlight: TRUE
syntaxHighlightOnlyLang: NO

  1. Support Staff 1 Posted by Brett on 29 Oct, 2018 03:26 PM

    Brett's Avatar

    I'm unable to replicate your results using the file provided and the settings you list. Does this issue occur every time you export a paginated PDF?

  2. 2 Posted by Yaroslav on 05 Nov, 2018 05:37 PM

    Yaroslav's Avatar

    Here's the doc the screen of the file settings and the result pdf with the bug (now the TOC are printed on the very first page while the H1 printed on the second one.

    Also outline mode set to decimal. And yep, this issue appears every time within the export.

  3. Support Staff 3 Posted by Brett on 05 Nov, 2018 07:00 PM

    Brett's Avatar

    I'm confused. Where do you want the H1 to print?

  4. 4 Posted by Yaroslav on 05 Nov, 2018 07:40 PM

    Yaroslav's Avatar

    I'm expecting that there'll be the follow order of the content:

    1. H1 as the title of the document
    2. TOC
    3. Content of the document by itself.

    And I'd could swear that I'd seen this behavior in some simple document.

  5. Support Staff 5 Posted by Brett on 06 Nov, 2018 03:13 AM

    Brett's Avatar

    Table of contents defaults to the top of the document. You can manually place it in the document using the tag:

    <!--TOC-->

    Any headlines before the TOC are excluded from the contents listing.

    Thanks,
    Brett

  6. 6 Posted by Ярослав on 06 Nov, 2018 06:08 AM

    Ярослав's Avatar

    Ah, I get it. May bad, thank you!

    С уважением,
    Яшин Я.Н.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Копия_Annex_No._1.pdf 34.1 KB
  • Annex_No._1.md 1.92 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac