no typographical apostrophes and quotation marks in this latest Marked 2

Peter's Avatar

Peter

03 Aug, 2018 08:52 PM

// Please enter a detailed description of the issue // Description of the issue: Hello Brett, this is the issue: no typographical apostrophes and quotation marks in this latest Marked 2.

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. normal, any which way I tried.
  2. Checked preferendes.
  3. ended by doing it by hand. This was one of the best features of Marked 2. Using Sierra 12.6, not upgrading to HiSierra.

// If applicable please attach a sample document that causes the issue for you.

Sample done, not the md file: fromoutoftheblue.com the Kubrick story.

// Configuration (do not edit) Marked 2 953 (Mac App Store)

macOS Version: 10.12.6

additionalMathJaxConfig:
allowPageBreakInCode: TRUE
bookTxtIsLeanpub: TRUE
summaryMdIsGitBook: TRUE
codeIsPoetry: TRUE
codeCanWrap: TRUE
collapsibleHeadlines: TRUE
convertGithubCheckboxes: TRUE
convertYAMLToMMD: TRUE
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: swiss
defaultProcessor: MultiMarkdown
enableMiniMap: TRUE
excludeBlockQuotesFromCounts: TRUE
excludeFootnotesFromCounts: TRUE
excludeVerbatimFromCounts: TRUE
excludeCaptionsFromCounts: TRUE
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: TRUE
h1IsPageBreak: TRUE
h2IsPageBreak: TRUE
hrIsPageBreak: TRUE
includeMathJax: TRUE
limitTextWidth: TRUE
minimalJavaScript: TRUE
outlineModeExtensions:
permissionGranted: TRUE
printHeaderBottomLeft:
printHeaderBottomRight:
printHeaderFirstPage: TRUE
printFooterFirstPage: TRUE
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: TRUE
removeMetadataForPreview: TRUE
removeYAMLHeaders: TRUE
scrollToEdit: TRUE
shouldDetectCritic: TRUE
shouldHighlightMarkupErrors: TRUE
shouldLoadCritic: TRUE
syntaxHighlight: TRUE

  1. Support Staff 1 Posted by Brett on 03 Aug, 2018 09:02 PM

    Brett's Avatar

    Hi Peter,

    Do you have Preferences->Style "Generate typographically correct quotes
    and punctuation" checked?

    -Brett

  2. 2 Posted by Peter on 04 Aug, 2018 03:51 PM

    Peter's Avatar

    Hi Brett,

    Yes. Here's a quick screenshot -

  3. Support Staff 3 Posted by Brett on 06 Aug, 2018 01:16 PM

    Brett's Avatar

    I'm going to recommend deleting your preference file. Unfortunately that
    means re-setting up Marked, but my best guess is that something
    corrupted and it's not registering the preference for smart typography.

    The file is located at
    ~/Library/Containers/com.brettterpstra.marked2/Data/Library/Preferences/com.brettterpstra.marked2.plist.
    Delete that and all of the cache files that have the same name but
    random extensions. Empty the trash and reboot your machine (to clear out
    cached preferences). Then launch Marked 2 again and see if the issue is
    resolved.

    Instead of deleting in the instructions above, you can also move the
    file to your Desktop (just the .plist, still delete the random extension
    files) and test after a reboot. If it changes nothing you can quit
    Marked and move the file back into place to restore your previous
    preferences.

    -Brett

  4. 4 Posted by Peter on 06 Aug, 2018 08:06 PM

    Peter's Avatar

    Hi Brett,

    OK, just deleted +/or moved that stuff. Tried without restarting the computer, no change. I'll need to wait to restart, so I'll get back later on that. If necessary I can (can't I) delete the app and re dl it from Mac store.

    I think something like this happened in the Yosemite era, but you had already posted an update by the time I sent a note to you.

    Thanks,

    Peter

  5. Support Staff 5 Posted by Brett on 06 Aug, 2018 08:10 PM

    Brett's Avatar

    The restart is needed as current versions of macOS cache preferences so
    heavily that as soon as you delete the file it writes the old
    preferences back to disk upon next launch. So do test with the reboot
    before giving up on that.

    Reinstalling the application won't really affect this; if it's a
    preference issue, those will persist between installations.

    The only other thing I can think of is a possible encoding issue in the
    document. Can you post a sample document that you can verify does not
    get its typography "smartened?"

    -Brett

  6. 6 Posted by Peter on 07 Aug, 2018 08:41 PM

    Peter's Avatar

    Hi Brett,

    After deleting everything except the app itself and restarting, nothing had changed, but I did some experimenting ... and it's not your fault. I found the culprit. Explanation follows.

    I opened a previously fine .md file in Marked 2 - it was fine in Marked 2, as before. I examined these two files - the current one that had been the problem and the earlier file - to see if there was a difference anywhere. Was it the asterisks in the title? No. I tried removing one apostrophe, then replacing it (in TextWrangler) and Marked 2 made the correct replacement. That was the problem. I replaced all the apostrophes and quote marks and Marked 2 did its thing perfectly.

    Here's what happened. I used the new/newish Highland app to compose the draft of this story, then copied and pasted it into TextWrangler (I use BBedit too, but that is reserved for another project). Highland uses some kind of non-plain apostrophes and quote marks. There's no preference in Highland indicating this and it's supposed to be a markdown editor. While I hand replaced the apostrophes and quotes in the experiment, I see that I could also have used TextWrangler's "straighten quotes" for this and that would work. I'll have to remember that if I use Highland again for this kind of thing.

    So all is well and you don't have to do any update for this. Apologies to you for the concern this caused. I hope the explanation was helpful and you can make use of it somehow.

    Further workflow info IYI: I'm currently using one of the static site generators for the basics, page and index/list files. It works but I do not like its built-in markdown converter. I always replace the body of the article with the Marked 2 html (and edit again with class names etc).

    Thanks,
    Peter

    ps. wrote this before seeing your reply.

  7. Support Staff 7 Posted by Brett on 07 Aug, 2018 08:57 PM

    Brett's Avatar

    Thanks for the update! I'm actually working on Highland 2 support at
    this moment, so I'll see if I can get any info from them on this.

    -Brett

  8. 8 Posted by Peter on 07 Aug, 2018 09:48 PM

    Peter's Avatar

    Thanks Brett. Hope that works out with Highland 2. They probably were not expecting this kind of use for the app.

    I did just see they have footnotes on their roadmap - that is something only Marked 2 does as far as I have seen.

    Peter

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac