Mathjax fails mid-document.

Bill Raynor's Avatar

Bill Raynor

14 May, 2018 01:12 PM

// Please enter a detailed description of the issue // Description of the issue:

Marked stops supporting Mathjax midway thruoug a document. Given a short (2614 words) document, Marked will translate the Mathjax/latex markup for a while, then rather abruptly stops and renders something else. In the attached files, the pdf fails starting in page 3. For comparison 1writer renders this document correctly (but does not allow you to save the rendered PDF).

// Please enter a list of steps required to reproduce the issue // Steps to reproduce:

  1. Open attached file in, say, nvAlt or BBEdit and in Marked 2.
  2. Scroll down to line 70 in the txt file, and the equivalent line in the PDF. (on page 3)
  3. The render should show a 훕 with a b subscript. Instead it renders the word tau in italics with a b subscript

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit) Marked 2 946 (Direct)

macOS Version: 10.13.4

additionalMathJaxConfig: {
"HTML-CSS": { messageStyle: "normal", linebreaks: { automatic: false } }, tex2jax: { inlineMath: [["$","$"],["\(","\)"]], displayMath: [["$$","$$"],["\[","\]"]], processEscapes: true }, TeX: { Macros: { tr: "{\scriptscriptstyle\mathrm{T}}", } } }

allowPageBreakInCode: TRUE
bookTxtIsLeanpub: TRUE
summaryMdIsGitBook: TRUE
codeIsPoetry: TRUE
codeCanWrap: TRUE
collapsibleHeadlines: TRUE
convertGithubCheckboxes: TRUE
convertYAMLToMMD: TRUE
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 0
defaultProcessor: MultiMarkdown
enableMiniMap: TRUE
excludeBlockQuotesFromCounts: TRUE
excludeFootnotesFromCounts: TRUE
excludeVerbatimFromCounts: TRUE
excludeCaptionsFromCounts: TRUE
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: TRUE
h1IsPageBreak: TRUE
h2IsPageBreak: TRUE
hrIsPageBreak: TRUE
includeMathJax: TRUE
limitTextWidth: TRUE
minimalJavaScript: TRUE
outlineModeExtensions:
permissionGranted: TRUE
printHeaderBottomLeft:
printHeaderBottomRight:
printHeaderFirstPage: TRUE
printFooterFirstPage: TRUE
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: TRUE
removeMetadataForPreview: TRUE
removeYAMLHeaders: TRUE
scrollToEdit: TRUE
shouldDetectCritic: TRUE
shouldHighlightMarkupErrors: TRUE
shouldLoadCritic: TRUE
syntaxHighlight: TRUE

  1. 1 Posted by Bill Raynor on 14 May, 2018 01:19 PM

    Bill Raynor's Avatar

    It was due to a conflict between the mathjax script at the end of the document (needed for 1Writer) and my Marked preferences. Turn off mathjax (Preferences->Style tab at bottom) and the code works as desired.

    Brett: the label "Enable MathJax" is somewhat misleading. Perhaps "include MathJax script" would be more accurate.

    Thanks

    Bill

  2. Support Staff 2 Posted by Brett on 14 May, 2018 04:11 PM

    Brett's Avatar

    I will take the suggestion under serious consideration.

    Thanks,
    Brett

  3. 3 Posted by Bill Raynor on 18 May, 2018 03:06 PM

    Bill Raynor's Avatar

    Brett,
    just downloaded 2.5.14 and saw the change in the Preferences -> Style "Include scripts:" subpanel.

    Thanks for considering my suggestion.

    Regards.

    Bill

  4. Support Staff 4 Posted by Brett on 18 May, 2018 03:09 PM

    Brett's Avatar

    :)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Kendall_Tau_Goodman_Gamma.txt 18.4 KB
  • Kendall_Tau_Goodman_Gamma.pdf 173 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac