The recent update broke MathJax

Teng's Avatar

Teng

14 May, 2018 11:20 AM

Hi,

Found out that after an update this afternoon, everything with a backslash in math functions fails.

It seems single blackslashes are processed into double backslashes, and are rendered into a new line.

This is really upsetting.

Thanks,
Teng

  1. 1 Posted by Teng on 14 May, 2018 11:21 AM

    Teng's Avatar

    Just restore a version I had no problems with a week ago. The same file fails to render properly now.

    Hope this is helpful with troubleshooting

  2. Support Staff 2 Posted by Brett on 14 May, 2018 12:06 PM

    Brett's Avatar

    Have you changed the base configuration dropdown at all? Is it possible
    that you were using Discount (GFM) previously (it escapes differently).
    The fact that you're seeing the same result on an older version fits my
    belief that I didn't make any changes to the math handling that would
    have affected this, but your configuration would have persisted when you
    downgraded, so it seems reasonable that something in your configuration
    may have changed.

    -Brett

  3. 3 Posted by Teng on 15 May, 2018 04:55 AM

    Teng's Avatar

    Hi Brett,

    Thanks for the reply, but the problem is not resolved.

    In the spirit of experiment I tried every combination of Multimarkdown/GFM x any rendering engine. My discoveries:

    • No inline Tex blocks with surrounding $ work any more — not even a $x$ works in line, with GFM and any math rendering engine.

    • The caret sign (^) seems to take precedence in rendering in the new version. Div-level Tex blocks with $$ started working again once I escaped every ^

  4. 4 Posted by Teng on 15 May, 2018 04:59 AM

    Teng's Avatar

    And upon further review, opening and closing an inline clause with \\( and \\) seems to work perfectly. It's odd the support for $ was dropped...

  5. Support Staff 5 Posted by Brett on 15 May, 2018 12:46 PM

    Brett's Avatar

    I've had another similar report, would it be possible for you to provide a text file, as well as the output of Help->Report an Issue? If you're using a custom MathJax configuration, could you include that as well?

    Thanks,
    Brett

  6. Support Staff 6 Posted by Brett on 15 May, 2018 01:09 PM

    Brett's Avatar

    I found the issue, fixed in the next update.

  7. 7 Posted by Peter Crozier on 15 May, 2018 02:05 PM

    Peter Crozier's Avatar

    I have a similar but opposite problem in that \\( ... \\) fails when the Latex expression contains a backslash but works otherwise. Using $ ... $ works.

    As an experiment I tried triple backslashes and that works for Latex with backslash expressions but fails for simple ones.

    I expect that you have already fixed this per #6 but here is an example you might want to verify.

  8. 8 Posted by Peter Crozier on 15 May, 2018 02:08 PM

    Peter Crozier's Avatar

    OK that attachment was blocked. Here is the example as plain text:
    ~~~ Works: block \[\tau = 2 \pi\]

    Fails: inline \\(...\\) \(\tau = 2 \pi\).

    Works: inline $...$ $\tau = 2 \pi$.

    But this \(a x^{2} + 2b x y + y^{2}\) works. Something to do with backslashes in the expression I think, as this works with triple backslashes:

    Works: inline \\\(...\\\) \(\tau = 2 \pi\).
    ~~~

  9. 9 Posted by Peter Crozier on 15 May, 2018 02:20 PM

    Peter Crozier's Avatar

    Oops. That worked in the preview but when posted the double slashes have been reduced to single single slashes. Also the triple slashes went to one.

    I think you get the picture. I give up.

  10. 10 Posted by Peter Crozier on 16 May, 2018 11:43 AM

    Peter Crozier's Avatar

    Fixed in 2.5.14. Thanks.

  11. Support Staff 11 Posted by Brett on 16 May, 2018 12:25 PM

    Brett's Avatar

    Excellent. Thanks for helping debug!

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac