Marked 2.5.13 (946) and Scrivener problem

pergosterlie's Avatar


13 May, 2018 05:56 PM

When choosing custom processor and opening a Scrivener project Marked 2 will go into a loop and create several documents in my Scrivener project with the same name as the Scrivener project itself. I will have to kill Marked to stop the process. Am I doing something wrong? I have the same set up for the pandoc post processing as I always had.

  1. Support Staff 1 Posted by Brett on 13 May, 2018 06:43 PM

    Brett's Avatar

    What version of Scrivener are you using? Can you provide a sample
    document that replicates the issue?


  2. 2 Posted by pergosterlie on 14 May, 2018 12:51 PM

    pergosterlie's Avatar

    Sorry, I forgot that I am using Scrivener 3.0.2. The problem occurs with every Scrivener file. Attached is a file where the problem has happened. I can see that the message "Loading MathJax..." is displayed several timens until I kill Marked 2


  3. Support Staff 3 Posted by Brett on 14 May, 2018 04:22 PM

    Brett's Avatar

    I can see that it's happening for you by the excess duplicates in the Scrivener research folder, but it's not happening locally for me. Could you provide the following?

    1. The output of Help->Report an Issue
    2. The content of the fields in your custom pre/processors
    3. A list of (seemingly obvious) steps you use to open the document


  4. 4 Posted by pergosterlie on 14 May, 2018 06:13 PM

    pergosterlie's Avatar

    Thanks a lot for your kind and quick help.

    Here is the result of the Help->Report an Issue
    1) Se last part
    2) The content is: /Users/pergosterlie/Dropbox/pandoc/ where contains:

    export HOME=/Users/pergosterlie
    pandoc -r markdown -w html -s --mathjax --bibliography ~/Dropbox/pandoc/bib/bibliografi.bib --csl ~/Dropbox/pandoc/apa5.csl

    3) I open Marked2 wich will open the Scrivener with the document

    // Please enter a detailed description of the issue
    // Description of the issue:

    // Please enter a list of steps required to reproduce the issue
    // Steps to reproduce:


    // If applicable please attach a sample document that causes the issue for you.

    // Configuration (do not edit)
    Marked 2 946 (Direct)
    macOS Version: 10.13.4
    allowPageBreakInCode: TRUE
    bookTxtIsLeanpub: TRUE
    summaryMdIsGitBook: TRUE
    codeIsPoetry: TRUE
    codeCanWrap: TRUE
    collapsibleHeadlines: TRUE
    convertGithubCheckboxes: TRUE
    convertYAMLToMMD: TRUE
    defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML-full
    defaultPreviewStyle: 102
    defaultProcessor: MultiMarkdown
    enableMiniMap: TRUE
    excludeBlockQuotesFromCounts: TRUE
    excludeFootnotesFromCounts: TRUE
    excludeVerbatimFromCounts: TRUE
    excludeCaptionsFromCounts: TRUE
    folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
    githubNewlines: TRUE
    h1IsPageBreak: TRUE
    h2IsPageBreak: TRUE
    hrIsPageBreak: TRUE
    includeMathJax: TRUE
    limitTextWidth: TRUE
    minimalJavaScript: TRUE
    permissionGranted: TRUE
    printHeaderFirstPage: TRUE
    printFooterFirstPage: TRUE
    processHTMLFiles: TRUE
    removeMetadataForPreview: TRUE
    removeYAMLHeaders: TRUE
    scrollToEdit: TRUE
    shouldDetectCritic: TRUE
    shouldHighlightMarkupErrors: TRUE
    shouldLoadCritic: TRUE
    syntaxHighlight: TRUE

  5. Support Staff 5 Posted by Brett on 14 May, 2018 07:06 PM

    Brett's Avatar

    Ok, I'm able to replicate the issue when Marked is set to open Scrivener
    automatically. Please disable that option for now and just hit ⌘E to
    open Scrivener while I work on tracking the bug down.


  6. 6 Posted by pergosterlie on 15 May, 2018 05:47 AM

    pergosterlie's Avatar

    Thanks again. Great help.
    There is one more problem: It seems that MathJax does not render mathematical expressions properly. Ex: \frac{2}{3} turns into rac23 and \int into just int (should be an integral sign). That happens both in case I enable the custom processor or not.

  7. Support Staff 7 Posted by Brett on 15 May, 2018 12:53 PM

    Brett's Avatar

    Do you have MathJax enabled under Style Preferences, and are you using a
    custom configuration at all? I've had a few reports of MathJax issues,
    so I'm trying to track down what's causing them.


  8. 8 Posted by pergosterlie on 15 May, 2018 04:24 PM

    pergosterlie's Avatar

    I have MathJax enabled under Style Preferences

    I get the same result when I use pandoc with mathjax enabled as a custom processor (se configuration in previous post)

  9. Support Staff 9 Posted by Brett on 15 May, 2018 10:52 PM

    Brett's Avatar

    I believe I have this fixed, please watch for the 2.5.14 update soon.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac