Version 2.5.13 (946) – diacritic signs in TOC etc.

Bertil's Avatar

Bertil

12 May, 2018 06:00 PM

Hi!
I just installed version 2.5.13 (946). Looks like links in a document's TOC stop working as soon as there is a diacritic sign in the headline (difficult to avoid when you live in Sweden!). Also, same thing occurs when using diacritic signs in cross-reference ID:s. It worked in the previous versions, hopefully it will work again!

All the best,
Bertil

  1. Support Staff 1 Posted by Brett on 14 May, 2018 04:18 PM

    Brett's Avatar

    Could you provide a test document? It seems to be working fine for me.

    In cross-reference IDs, you'll need to use the percent-encoded version
    of the headline. Marked actually strips the % symbols out when
    generating the TOC links, but it will still jump to `Headline%3C%A2` if
    the anchor is `#Headline%3C%A2` or `#Headline3CA2`. You can see the
    generated IDs (which can differ between the MultiMarkdown and Discount
    processors) in the source view (⌘U).

    -Brett

  2. 2 Posted by Bertil on 14 May, 2018 05:50 PM

    Bertil's Avatar

    I think the percent-encoding solved my problem. Thank you for helping me!

    Bertil

  3. Support Staff 3 Posted by Brett on 14 May, 2018 07:07 PM

    Brett's Avatar

    Sure thing!

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac