Problems running custom Pandoc processor

Justin's Avatar

Justin

04 Dec, 2017 09:04 PM

I'm trying to used Marked 2 to view in real time a document I'm composing in Scrivener with Pandoc markdown. I'm told this requires setting up a custom processor. This worked for me fine until the recent Pandoc update, which occurred right around the time I acquired a new computer and updated to High Sierra.

I'm running the processor with a bash script, which I updated based on the new Pandoc syntax, but when I open my .scriv file, I just see a blank screen.

Here's my bash script:

#!/bin/sh export HOME=/Users/[me]/
pandoc --filter pandoc-crossref --filter pandoc-citeproc -r markdown -w html -s --bibliography ~/Dropbox/Citation/library.bib --csl ~/Dropbox/Citation/cite-styles/apa.csl --variable tables=1 --pdf-engine=xelatex

Any thoughts? Thanks in advance for any wisdom you can offer.

—Justin

  1. Support Staff 1 Posted by Brett on 05 Dec, 2017 07:03 PM

    Brett's Avatar

    Does the Help->Show Custom Processor Log offer any information?

    -Brett

  2. 2 Posted by Justin Quam on 05 Dec, 2017 07:13 PM

    Justin Quam's Avatar

    I'm afraid that doesn't come up as an option. Am I doing something wrong?

    [image: Screenshot 2017-12-05 14.11.52.png]

  3. Support Staff 3 Posted by Brett on 05 Dec, 2017 08:12 PM

    Brett's Avatar

    Sorry. Under Preferences->Advanced at the bottom turn on Debug Mode
    (All). Then you'll see the option under the help menu.

  4. 4 Posted by Justin Quam on 06 Dec, 2017 04:18 PM

    Justin Quam's Avatar

    Excellent — thanks for the clarification.

    In the meantime I downloaded the most recent public beta of Marked 2, which
    seems to have addressed my issue. At any rate, the viewer now displays my
    text. It doesn't seem, though, to be implementing elements of the markdown
    beyond citations. For example, numbering doesn't seem to be working
    properly:

    [image: Screenshot 2017-12-06 11.15.48.png]

    ...nor are headers.

    I'm quite new to Pandoc, so please let me know if I'm doing something
    clearly wrong.

    I've also attached the custom processor log in case that's useful.

    Thanks so much for taking the time to share your advice.

    Yours,

    Justin Quam

  5. Support Staff 5 Posted by Brett on 06 Dec, 2017 05:11 PM

    Brett's Avatar

    Is that numeric list done using Scrivener formatting, or with
    4-space/1-tab indents per Markdown style?

    -Brett

  6. 6 Posted by Justin Quam on 06 Dec, 2017 05:45 PM

    Justin Quam's Avatar

    Thanks for getting back to me so quickly.

    I had made the list via 1-tab indents, but replacing them with spaces seems
    to have worked.

    Any idea why my headers aren't working? I've tried using both #s and lines
    of ==== or ---- underneath.

    Yours,

    Justin

  7. Support Staff 7 Posted by Brett on 07 Dec, 2017 03:03 PM

    Brett's Avatar

    Could you attach a sample doc with headers that don't work?

    -Brett

  8. 8 Posted by Justin Quam on 07 Dec, 2017 04:40 PM

    Justin Quam's Avatar

    Hi Brett,

    Attached is a section of the chapter I'm working with it. When I export
    this from Scrivener to a text file, Marked 2 reads the headers just fine.
    This makes me wonder if there's a switch in Scrivener that I'm failing to
    flip. Let me know what you think.

    JQ

  9. Support Staff 9 Posted by Brett on 07 Dec, 2017 05:53 PM

    Brett's Avatar

    I meant attach a full scrivener document for me. I need to try to
    replicate the issue as you're seeing it. Even if you just copy that page
    into a new document and verify that headers aren't working for you with
    that file, I can test from there.

    -Brett

  10. 10 Posted by Justin Quam on 07 Dec, 2017 06:00 PM

    Justin Quam's Avatar

    Ah! I understand. Here you are.

  11. Support Staff 11 Posted by Brett on 12 Dec, 2017 02:53 PM

    Brett's Avatar

    Ok, so it's a weird one that I'll need to look into further. In the meantime, are you opposed to using ATX headers? (#)

    # Background to the Present Study
    
    ## Interpersonal Resource Frameworks
    
  12. 12 Posted by Justin Quam on 12 Dec, 2017 03:14 PM

    Justin Quam's Avatar

    I can switch to that, yes. Thanks for all your help so far!

  13. Support Staff 13 Posted by Brett on 12 Dec, 2017 03:15 PM

    Brett's Avatar

    Sure thing :).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac